Dead Space 2 > General Discussions > Topic Details
Mechorive Bread Co. Feb 22, 2013 @ 6:37am
I can't kill stross
It's the quick time event after you previously see him take out the chicks eye, and fight the space ♥♥♥♥♥♥ quefing missles. No matter how hard I mash E he still stabs me in the eye, I've tried switching it to my mouse to click faster, still no luck. I need help, I've been wanting to beat this game for a few weeks, and this is the only thing that stands between it.
Showing 1-15 of 15 comments
< >
Corban Feb 22, 2013 @ 7:43pm 
click faster.
Lil_Ese_Ggee Mar 2, 2013 @ 12:19pm 
I have the same problem, I tried a new game, changing letter, adjusting two letter E's but nothing he keeps killing me and it's soooo annoying!
jacob123443211 Apr 10, 2013 @ 8:06pm 
Try switching the resoulution screen size lower I heard this might help solve this issue its not the keyboard or the mouse its a coding in the game some of the games released had that issue on the pc.
Lil_Ese_Ggee Apr 11, 2013 @ 7:14pm 
ohh really I'll try that real quick
Mechorive Bread Co. Apr 11, 2013 @ 7:24pm 
didn't work for me :/
Lil_Ese_Ggee Apr 11, 2013 @ 8:18pm 
yea me neither.
-SC- £εɠεɲᴆ☠ϩϮʀİкεƶ Apr 19, 2013 @ 5:10pm 
soultion i found was window it and make it 800x600 and it should work
The_Insane_Potato May 1, 2013 @ 1:47pm 
i had the same problem but only when you fly from one train to the other. what i did was put it on a different, better computer. do that if you have one, a desktop will work well, thats what i used.
Lil_Ese_Ggee May 1, 2013 @ 3:27pm 
yea that'll probably work, my laptop sucks, it can barely run Dead Space 2
Mechorive Bread Co. May 1, 2013 @ 3:28pm 
I have a laptop and it ran perfectly for me, no lag, hell I can even run dues ex, but moment stross trys to shank me, instant death
Lil_Ese_Ggee May 1, 2013 @ 3:29pm 
Have you tried starting the whole campaign over?
Mechorive Bread Co. May 1, 2013 @ 5:19pm 
I really would ahte to do that, I've kinda stopped playing it for a bit since stross.
Lil_Ese_Ggee May 1, 2013 @ 5:54pm 
I know it got kinda boring passing it over just because of Stross lol
The_Insane_Potato May 2, 2013 @ 2:07pm 
go into your task manager, go to proccesses, find steam.exe, right click, go to set priority to high and that should fix it.
ICS May 6, 2013 @ 4:02am 
I would disable vertical sync. It has issues such as mouse lag and propably keyboard lag too. It might be that the commands aren't getting through due to that. I had no issues with pressing E at any point of the game and i have vsync off from the start. Resolution 1920x1080.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Feb 22, 2013 @ 6:37am
Posts: 15