Dead Space 2 > General Discussions > Topic Details
Coneman The Bongbarian Feb 15, 2013 @ 10:26am
.:DS2 FPS Too High and cant vsync? Fix located here!:.
Hi all i had an issue lately where i could not limit my fps to 60 (Via nvidia control panel or D3Doverider) leading to 200 fps and massive issues playing (as we all know the 30fps ingame vsync is no good)

I tried alot of fixes from .ini file and console Nothing worked , You might be having the same problem and I may have a fix for you

My current system specs are as follows: i5 3570k Oc'd to 4.4ghz, 8gb corsair vengance ram, Asrock z77 extreme4, GTS 450 1gb oc'd.

On my old system (core 2 duo) everything worked fine but since my upgrade 200fps was comon

Fix 1:
Locate deadspace 2 exe file (steam/steamapps/common/deadspace2/ is normally default)
Right click on the .EXE select the Compatability tab check the box to run in Windows XP service pack 3(or whatever number you have) then choose OK

Now this might be all you have to do but considering I have a new generation quad core at a high overclock just in case I limited the .exe from using more than two cores

Fix 2:
You can do this by running the game, opening task manager and finding the deadspace2.exe in your task list. Right click and select "Set Affinity" Uncheck all except Core 0 and Core 1 then hit OK

You are good to go, you should now be able to limit the game to 60fps via your drivers with no issues!
Let me know if this fix helped you :)
Last edited by Coneman The Bongbarian; Feb 17, 2013 @ 10:20am
Showing 1-6 of 6 comments
< >
Monocerotis Oct 25, 2013 @ 11:16pm 
Neither worked for my Windows 8.1
Coneman The Bongbarian Oct 26, 2013 @ 5:13am 
:( i wrote this before 8.1 was released Infact I can't tell you if it works for 8 at all, I'm using 7
Monocerotis Oct 26, 2013 @ 6:04pm 
Originally posted by Coneman The Bongbarian:
:( i wrote this before 8.1 was released Infact I can't tell you if it works for 8 at all, I'm using 7
Yes.. Still trying to get it to synch to 60. I'm still hitting about 300 fps or 30 on vsync.
meatee Oct 28, 2013 @ 3:29pm 
Could this be an overclocking issue? I'm not overclocking anything and the game runs at a rock-solid 60fps just by disabling the in-game vsync and then enabling vsync from the nVidia control panel.

Core i7-2600 3.4GHz
12GB Ram
GTX 560-Ti (1.25GB Version)
Windows 8.1 Pro
Monocerotis Oct 30, 2013 @ 2:57pm 
Originally posted by meatee:
Could this be an overclocking issue? I'm not overclocking anything and the game runs at a rock-solid 60fps just by disabling the in-game vsync and then enabling vsync from the nVidia control panel.

Core i7-2600 3.4GHz
12GB Ram
GTX 560-Ti (1.25GB Version)
Windows 8.1 Pro

I have the latest AMD drivers. It still runs at 30 or 300 fps, with or without in-game and/or AMD Catalyst vsync (override).

Core i7-960 3.2 GHz
24GB Ram
AMD 7970 (3.1 GB)
Windows 8.1 Pro with Media Center
Coneman The Bongbarian Oct 30, 2013 @ 7:56pm 
I am overclocked (i5 3570k @ 4.6ghz) and doing the fix i posted worked for me for win 7 ultimate. Try D3D over rider might help you guys out
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Feb 15, 2013 @ 10:26am
Posts: 6