Dead Space 2 > General Discussions > Topic Details
Coneman The Bongbarian Feb 10, 2013 @ 5:29pm
Deadspace 2 MASSIVE issues
So I recently upgraded my PC DS2 played absolutely fine on my old core 2 duo, but now my PC is just too damn quick for this game! (200fps during play makes it impossible and i've tried the vsync @30fps which is too slow)

So i then tried forcing 60fps Vsync from nvidia control panel (it wont work Vsync not active while in game still 200fps) and the same with D3Doverider

Anyone got a work-around for this else i'll never be able to play it :(
Showing 1-15 of 19 comments
< >
Wesley Charles Feb 10, 2013 @ 5:36pm 
thats wired whats your specs
Coneman The Bongbarian Feb 10, 2013 @ 5:38pm 
i5 3570k, 8gb ram, Asrock z77 extreme 4, GTS 450 1gb oc'd
Wesley Charles Feb 10, 2013 @ 5:41pm 
thats wired my specs are i7 8gb ram gtx 650 2gb sc are you overclocking
Coneman The Bongbarian Feb 10, 2013 @ 5:43pm 
yeah to 4.4ghz, but that shouldn't effect my ability to force Vsync on surely
Wesley Charles Feb 10, 2013 @ 5:46pm 
theres your problem right there the game is based on useing prosscer power more then grapics card and in other games you may notice that the soundtrack aint keeping up with the vidoe thats why i dont over clock so i dnt have problems with my games
Last edited by Wesley Charles; Feb 10, 2013 @ 5:49pm
Coneman The Bongbarian Feb 10, 2013 @ 5:49pm 
DS2 is literally the only game i have an issue with but thanks ill drop to stock for playing and see if that helps
Wesley Charles Feb 10, 2013 @ 5:51pm 
i may be wrong im not expert i just saying what i think coz 4.4 ghz is high il ask few people who know more about computers then i do and i get back to you
PowerHaus930 Feb 10, 2013 @ 10:40pm 
If you are getting 200fps putting your CPU clocks back to stock isn't going to help. and I ghighly doubt that 4.4GHZ is a problem. I had the same problem with really high FPS but like you said for some reason Vsync is set at 30FPS. I have an ATI card so I downloaded a program called RadeonPro which allowed me to set an FPS cap at 60. I'm sure there has to be a program similar to that for Nvidia cards...
W.Sc®| link3rd Feb 11, 2013 @ 1:07am 
u can download a program called "D3Doverrider" this allows the game to be capped at 60 fps. I use it for Dead Space 1, 2 & 3... works like a charm!
Coneman The Bongbarian Feb 11, 2013 @ 9:52am 
Now have found the perfect fix! Limit deadspace 2 .exe to 2 cores (via task manager) + run the exe in windows XP compatability mode. Drivers are now limiting to 60fps always

Still running with my Overclock and everything seems fine
Spider-Man Feb 11, 2013 @ 10:44pm 
I'm not sure what's so wrong about having high FPS. Isn't that a good thing?
Russ Angel Feb 12, 2013 @ 1:08am 
Im on i7 gtx 580 no probs here
bloTTer Feb 15, 2013 @ 12:24am 
nvidia inspector can enable 60 fps vsynch with triple buffering...
Coneman The Bongbarian Feb 15, 2013 @ 10:12am 
Originally posted by The Dear Leader:
I'm not sure what's so wrong about having high FPS. Isn't that a good thing?

On a game like deadspace 2 No its not a good thing it literally plays the game too fast (As it is a console port) and it can be impossible to play or use the controlls in any effective way

To the rest of the people reading i did state before my fix that A. I tried limiting to 60fps (normal vsync) in Nvidia Controll panel and B. in D3Doverider they did not work untill Forcing deadspace2.exe to Windows XP compatability mode and i went ahead and limited Ds2 to using 2 cores only just in case
Last edited by Coneman The Bongbarian; Feb 15, 2013 @ 10:13am
Pellaeon Sep 23, 2013 @ 4:52pm 
Interesting. I have the same issue where I want to play at 60 and not 30 FPS with v-sync on. I don't see how limiting the cores would help with FPS, but I'll give it a try.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Feb 10, 2013 @ 5:29pm
Posts: 19