Dead Space 2 > General Discussions > Topic Details
OmNomMonster Jan 27, 2013 @ 5:17pm
Dead Space 2 Activation Loop
So i looked around on how to actually fix this and all the things suggested didnt work for me. Well i dont know why it worked but i renamed the exe in the Dead Space 2 folder which was originally called deadspace2 or something like that. I just renamed it and the game decided to work for some odd reason. People who are still having this issue can try this if nothing else has worked for you. Hopefully this does.
Showing 1-10 of 10 comments
< >
MBH.Ratman Feb 3, 2013 @ 8:39am 
Yeah renaming the Deadspace2.exe file to "DS2.EXE" resolved my issue. Thanks for the tip!
Karibou42 Feb 7, 2013 @ 10:10am 
It does works indeed, thx!
tbroark Apr 17, 2013 @ 5:02pm 
Hey guys, I'm having the same issue. When trying to rename the file, however, it fails to launch the game with "Failed to launch game: Missing Executable" error. I've searched around and nothing works, and I sure as hell am not installing piece of junk Origin.
Balt Apr 25, 2013 @ 2:37pm 
Hey same as bartender Tom, if i change the name it says that the executable is missing... (yes 2nd time I just come saying "Hey DS2 doesnt work for me either)
The worst thing is that it worked perfectly a few months ago... I just let it aside to play other things and now i cannot come back to it :'(
reinstalling could be the solution though, but that would suck, right?
cisticola Apr 25, 2013 @ 4:23pm 
Same here, stuck in a loop! Renaming file same as above!!
cisticola Apr 25, 2013 @ 4:45pm 
OK. Rename it to DS2.exe, but do not launch from Steam but from within the game folder. As a double precaution I set the game to run in Windows 7 compatibility & run as adminstrator. Just put as short cut to the games folder on desktop & just run it from there.
Garrett_Wilson Apr 26, 2013 @ 11:07am 
An alternate way to get the game to work:
open "run"
type "msconfig"
click on the "services" tab
and uncheck "Windows Management Instrumentation"
This will require a system restart.
After that, the game runs fine.
Devilswarchild Jan 26 @ 6:57pm 
ok heres a solution for those who have looked for solution on web and none worked. download the deadspace2.exe v2 crack and replace the exe file with the one from the crack and game will start right up
SenMithrarin85 Jan 28 @ 4:39am 
If you are using an nvidia optimus laptop, then set the "manage 3d settings" global to "high performance nvidia processor" prior to activating the game, and it'll activate and launch correctly.
Devilswarchild Jan 28 @ 1:16pm 
i dont have optimus
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Jan 27, 2013 @ 5:17pm
Posts: 10