Dead Space 2 > General Discussions > Topic Details
MaterialDfender Jan 20, 2013 @ 8:08pm
Dead Space 2 Activation Loop Problem
I just bought this game today. I know it is kind of old - but why is Steam allowed to sell this game and take my money when some people still cannot run it on their machines? I didn't read all the activation loop threads because I didn't know about the activation loop problem until after I bought it.

This sucks man - I dropped $20 on this game just to find out that people who bought it months ago still cant play it! And your gonna tell me Steam wasn't aware of this?

Now I'm going to call Steam just to hear them tell me that they can't help me and they cant refund my money.

What a load of crap.

ASUS Maximus IV Extreme -Z - LGA 1155 - Z68
Intel Core i7-2600K
NVIDIA GeForce GTX 660ti

Sure as ♥♥♥♥ is not my rig.
Showing 1-15 of 23 comments
< >
hashbasher15 Jan 21, 2013 @ 1:27pm 
Hey

I'm having the same problem too. I've been trauling the internet and I keep finding the same 2 solutions. The first being:

select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor


Problem is, I dont have this choice available to me and I dont know why.
I have an EVGA GTX 650ti so i dont know if this option isnt available for new graphics card.

Therefore I have to use the second method:

Run "msconfig.exe" then go to the "Services" tab. Scroll down and find "Windows Management Instrumentation" and "UNCHECK IT"
This method works, but BE CAREFUL as this turns of some Windows Security features. It's a ball ache but if you want to use this method, you'd have to restart your computer to affect this change, then when you have finished your session of Dead Space 2, then I recommend you "Check" it again before browsing the internet.

If anyone can suggest another method please let us know.
hashbasher15 Jan 21, 2013 @ 1:38pm 
AHA!!! Just read this and tried it.... IT WORKS!


"I recently upgraded to Win 8 and the game stoppped working (activation successful then nothing).

To get it working, I changed the compatability mode to Windows 7 for deadspace2.exe and set deadspace2.exe and activation.exe to run as administrator in properties."
MaterialDfender Jan 21, 2013 @ 4:01pm 
This did NOT work for me.

Followed instructions - went into msconfig, went into services, unchecked "Windows Management Instrumentation" - rebooted.

When it came back, tried to run game - asked me again for my activation code - only this time it didn't even go through because it said I didn't have an internet connection.

Checked my internet connection and it said I didn't have an Ethernet cable plugged in - which of course I did.

I want my money back.

hashbasher15 Jan 21, 2013 @ 4:03pm 
Damn I'm sorry to hear that. Maybe turning off WMI messes up ethernet settings. I connect wirelessly so i dont notice. If you have windows 8 did you try the 3rd method? Yeah I have seen a lot of people making this complaint, I'm really surprised EA and/or Valve havnt patched this yet
MaterialDfender Jan 21, 2013 @ 4:15pm 
Don't have Windows 8.
Brook Le Rouge Jan 23, 2013 @ 7:09pm 
I have the same problem, have been looking everywhere for help since 1 month. still hoping.
e-fiend Jan 24, 2013 @ 10:32am 
The same here. Much worse of a problem then not having a high texture pack (see the QQ over DS3)
Last edited by e-fiend; Jan 24, 2013 @ 10:32am
Nathanael777 Feb 25, 2013 @ 9:02pm 
I can't believe EA hasn't fixed this. I've tried every method I could find and more and nothing is fixing this for me. Between this and the impossible pc controls of DS1 there is no freaking way I'm buying DS3. Or any EA product in the near future. Would have been easier to just pirate the game.
Last edited by Nathanael777; Feb 25, 2013 @ 9:04pm
MaterialDfender Feb 26, 2013 @ 11:48am 
Not only that - I bought DS3 only to find that DS3 wouldn't start either!! It's a freakin joke! I finally ran across a thread where somebody else couldn't run DS3 and found that unplugging any external joysticks or controllers would solve the problem. I have a Razer Nostromo - as soon as I unplugged it, the game worked! Which sucks because I bought the Nostromo for a reason - I HATE USING THE KEYBOARD - which now I am forced to. And DS3 isn't even that great!

Nathanael777 Feb 26, 2013 @ 3:44pm 
Well just wasted my entire afternoon with EA's "support". After about 4 hours of troubleshooting and holding (not to mention the two hours of failed attempts to get on their chat) they told me they would investigate the issue and they gave me a 15% off coupon as a "token of good will". Like the first thing I want to do after getting off the phone is go to the Origin store and buy an overpriced game with 7$ off. If I dont see an email from them tomorrow I'm calling them up and demanding that they either refund my money or give me Dead Space 3 to play while I'm waiting for them to fix my freaking problem as a "token of good will".
Nathanael777 Feb 26, 2013 @ 9:30pm 
Got it. Rename the deadspace2.exe to DS2.exe. Worked like a charm.
MaterialDfender Feb 27, 2013 @ 9:29pm 
DUDE!! YOU ARE MY NEW BEST FRIEND!! IT FREAKIN WORKED!! I can't beleive after all this time - I actually get to play the game! Un-friggin-believable! Thanks for the due dilligence - I'm sure that anyone who reads this will appreciate your efforts.

I wonder if I can plug my Nostromo back in for DS2 (?) - I'll report back.....
pjlambo Mar 2, 2013 @ 5:37am 
changing the name of the exe file didn't work for me but I uninstalled the game from Steama and redownloaded it through that POS called Origin as I was able to use the same key code as the one Steam gave me. Still unable to get the game to load still getting that long activation error message :(
pjlambo Mar 2, 2013 @ 5:51am 
I got so upset with this issue I ended up buying the game for the X360, atleast you don't have to go jumping through hoops with all this DRM crap to get the game to run. You wonder why people who pay for games are often seeking out cracked copys of games due to this kind of BS.
e-fiend Mar 20, 2013 @ 11:25am 
Originally posted by Nathanael777:
Got it. Rename the deadspace2.exe to DS2.exe. Worked like a charm.

I don't understand why this should make a difference but hallelujah it worked!? A big thank you :)

I think you have to start the game from your game folder instead of Origin?
Last edited by e-fiend; Mar 20, 2013 @ 11:27am
Showing 1-15 of 23 comments
< >
Per page: 15 30 50