Dead Space 2 > General Discussions > Topic Details
seafoof Dec 29, 2012 @ 1:02pm
Downloaded Dead Space 2, but it won't open.
I open Dead Space 2, the activation thing keeps popping up, I enter the code it gave me, then Dead Space doesn't launch. Can someone help me please? I wanna play!
Last edited by seafoof; Dec 30, 2012 @ 12:42pm
Showing 1-15 of 15 comments
< >
AndyBybee Jan 2, 2013 @ 1:09pm 
i have the exact same problem, and i've been scurging the internet to find a solution, hopefully someone helps
seafoof Jan 2, 2013 @ 3:25pm 
I think it may the graphics. I have an Nvidia GeForce 640. But I don't know.
ShakeDeSnake Jan 2, 2013 @ 3:58pm 
I had the same problem with an ATI Radeon HD 5570.
A GeForce 640 should have no problem. Nvidia is better about compatibility.
Try to find up-to-date drivers for the card. That sounds like the issue. Good luck.
seafoof Jan 2, 2013 @ 4:45pm 
Well I downloaded the latest driver for my graphics card. Re-downloaded Dead Space 2. But still won't open after I verified the key code. Sigh.
[TG] Emonte Jan 3, 2013 @ 5:49pm 
Nvidia Geforce 460 SE, I know its a video card issue, but nothing I do fixes this problem. This issue has been around for a long time and its a shame EA or Valve have figured this out.
Catch the Bucket Jan 4, 2013 @ 12:30am 
I got the same problem here guys. I bought the pc on October, so its really new and strong. graphics card i got is this --> GeForce GTX 670M . So, as you can see i got no problem on the graph card. I bought the game through steam, and not a local shop, so either they must fix it, or i will ask for refund, and a 100% one ofc.
Black Watch Jan 4, 2013 @ 3:25pm 
I too have a high end system with GTX670. That's not the problem. Two solutions that work.
1. If you have an older Nvidia gpu, go to Nvidia Control Panel, then to 3D settings, then opt for high end graphics. For us with newer Nvidia gpu's, this option does not appear in the control panel.
2. The only way I have found I can play the game is to go to Windows Services and deactivate Windows Management Instrumentation. But this is a scary solution. The only way you should opt for this is if you only play single player, and then reactivate WMI as soon as you're done playing. WMI controls security, firewall, etc. Without it, Windows will not function properly.

I too am really annoyed about it. I find it especially annoying that Steam is completely ignoring the problem. They say go ask EA and EA says go ask Steam, since you downloaded it there. Total run-around.
psychodegu Jan 4, 2013 @ 4:43pm 
Not only that but it appears to a new problem, as this hasn't happen to me until today.
Just_a_Legend Jan 10, 2013 @ 11:12am 
go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

You should be working after the next activation
seafoof Jan 10, 2013 @ 3:32pm 
It works now! Thank you so much! It's weird that Steam never told me that. THANKS!:D


Originally posted by Just_a_Legend:
go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

You should be working after the next activation
daNi_theDog Jan 10, 2013 @ 6:20pm 
For those who still have the problem, try this:
Go to the game folder, right click on deadspase2, click properties, than compatibility, select run as administrator and apply. Than change the name of deadspace2 to deadspace2.exe and run it double clicking it, not from Steam.
I hope this will help somebody!
Aedwynn Jan 18, 2013 @ 4:19am 
Originally posted by daNi_theDog:
For those who still have the problem, try this:
Go to the game folder, right click on deadspase2, click properties, than compatibility, select run as administrator and apply. Than change the name of deadspace2 to deadspace2.exe and run it double clicking it, not from Steam.
I hope this will help somebody!

Didn't work for me, I just get the activation successful and no game, as per usual.


Originally posted by Just_a_Legend:
go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

You should be working after the next activation

I have an nVidea 9600GT and that option doesn't appear in my control panel.
pengols Jan 20, 2013 @ 3:08am 
I recently upgraded to Win 8 and the game stoppped working (activation successful then nothing).

To get it working, I changed the compatability mode to Windows 7 for deadspace2.exe and set deadspace2.exe and activation.exe to run as administrator in properties.
hadden18 Jan 20, 2013 @ 9:22am 
I bought his game some months ago, buit I started to play it until today, and I foiund some issues with the activation. The activator was telling me that it wasn´t able to connect to the internet. After a while navigating some forums I noticed that there seems to be a pattern of solutions related to uninstalling hamachi, which is a VPN software. I didn´t have hamachi, but anyway I cheched if I had other network connections appart from my Lan and my wireless and I found that I had other network connection from my motherboard that was used to broadcast the wifi and a copuple of others that were related to vm ware. I disabled them as they were from VM Ware and then I launched the activator again and It worked. So it seems that the activator is really weak and uses a random network connection, even if that connection is not connected to the internet or if it is just virtual, vpn, etc. So if you have multiple network connection try to disble them just to be sure that the activator uses a working connection.

But when the game was succesfully activated I had another problem that said that the game could not initialize the display. There is a solution in this forum that says I should disble desktop themes and virtual composition and run the game as administrator. After that the game worked very well and I´m halfway through it.

I have an old ATI HD 4800 btw.
hashbasher15 Jan 21, 2013 @ 1:36pm 
Originally posted by pengols:
I recently upgraded to Win 8 and the game stoppped working (activation successful then nothing).

To get it working, I changed the compatability mode to Windows 7 for deadspace2.exe and set deadspace2.exe and activation.exe to run as administrator in properties.

FANTASTIC!!! Thank you
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Dec 29, 2012 @ 1:02pm
Posts: 15