Dead Space 2 > General Discussions > Topic Details
AztecWarrior690 Nov 28, 2012 @ 12:13pm
Problem Help if possible please(resolved)
whenever i start my DS2 It asks my for my key and it'll say activation successful but my game wont launch, and it'l do this everytime I try to launch my game and its super irritating i might add
Last edited by AztecWarrior690; Dec 21, 2012 @ 9:44pm
Showing 1-13 of 13 comments
< >
daNi_theDog Nov 28, 2012 @ 2:47pm 
Are you using LucidLogix Virtu MVP? If so, try disabling it.
I had the same problem with another game and this fixed to me.
AztecWarrior690 Nov 28, 2012 @ 4:10pm 
nope nothing special like that
daNi_theDog Nov 28, 2012 @ 4:25pm 
Ok.
Also you can try run the ".exe" file from the directory of the game as administrator.
You know how? : pressing the right button of the mouse and go to "run as administrator"
Try it!
AztecWarrior690 Nov 29, 2012 @ 3:28am 
Just tried it but unfortunately the end result was the same :/. Like it'll like me activate the game in the activation wizard and that's it after I get an activation successful notification, nothing else happens, it won't launch the game from there. Anything else you can think of I can try?
AztecWarrior690 Nov 29, 2012 @ 3:29am 
I have a bunch of other games and i've never had this problem before, i've also tried reinstalling it several times, but to no avail.
AztecWarrior690 Nov 29, 2012 @ 3:58am 
everytime i go to launch it, it drags me through the verification wizard again as well.
AztecWarrior690 Nov 29, 2012 @ 4:17am 
Hey i figured out what it was, my graphics card settings needed adjusting, thanks for your help bud :)
daNi_theDog Nov 29, 2012 @ 4:19am 
Dont know why but it happend to me wright now.
Very strange!!!
I am trying to solve it.
If i fix it i will tell you.
daNi_theDog Nov 29, 2012 @ 4:21am 
How did you fix that?
AztecWarrior690 Dec 3, 2012 @ 6:44am 
I changed the settings in my nvidia graphics card control panel. i changed the 3d setting from auto to high-end graphics settings
The Universe Dec 20, 2012 @ 5:21am 
Have you completed the first initial setup? If you have, and Microsoft Visual Package C++ won't install properly, I know how to fix this. Go to Program Files(x86) then go to Steam. Click Steamapps. go to the file called 'common' and click Dead Space 2. go to 'install' and click the application called 'vcredist_x86_en' and MANUALLY install it. Just do this by double clicking it. Remember you have to have ADMINISTRATOR rights to install the file. After it has been installed, simply run the game on steam, and problems solved! ^-^
Ranguvar Snidanemici Dec 22, 2012 @ 4:07pm 
Wow....they still haven't fixed this?I stopped playing DS 2 because of this like 8 months ago with THIS same problem...I'm re-installing it (again) hoping there's some patch or something like this..really hope this works...it's a good game...i want to finish the story since i've left it on half D:
Leo Dec 25, 2012 @ 4:04pm 
no it wont fix for me
this game such a ♥♥♥♥ by steam

Steam support dont solve this kind of problem?^
I've been trying to contact the gods of the steam for so long time and it seems that they dont give a ♥♥♥♥ ... i dont know about the rules or make some legal action against it( i read about that it dont work anymore for Valve ). So im already ♥♥♥♥ed off. give me time and so be it!
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Nov 28, 2012 @ 12:13pm
Posts: 13