Dead Space 2 > General Discussions > Topic Details
Such Doge™ Apr 20, 2013 @ 10:50am
Dead Space 2 Does not work
Ok so anytime i try to play dead space 2 it asks for a activation code and i hit next and it says its successful and i hit ok, but nothing happens, i've looked everywhere on the internet but nothing works, steam wont open the game and my desktop cant start it, ive tried to change the file to deadspace2.exe also, please help!
Showing 1-15 of 18 comments
< >
Balt Apr 25, 2013 @ 2:26pm 
I have the same problem. I didnt try anything to solve it (for now) except coming to this forum and seeing this thread, but I felt like saying it.
So yes, "activation?" i give it, click, "activation successful", the window closes and... back on steam, where my status changes back from "playing dead space 2" to "online"
Dark_Frost May 21, 2013 @ 7:56pm 
did u double click on the one u renamed? bc it probably wont work by clicking play through steam
Buzz May 21, 2013 @ 8:24pm 
Here's what I had to do to get it to run. Downloaded it thru Steam, got the activation code. Went to my Origin Online App and registered the game thru Origin. Then deleted it from Steam, Dled it thru Origin. Activated it again, went to the game folder and renamed the deadspace2.exe to DS2.exe and launched it from the DS2.exe..now it runs. Crazy huh?
Espen May 22, 2013 @ 9:59am 
i have the same problem and nothing works. even origin wont start it
Gecks May 22, 2013 @ 11:44am 
Alright I found this on the web and it worked for me(I was having the same problem with the activation thing)
This is for all users using Nvidia Graphic with Optimus Technology

go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor: select high-performance Nvidia processor

Hopefully this works for some people
Such Doge™ May 22, 2013 @ 12:20pm 
Ya i have nvidia, but the problem is i dont see this prefered graphics processor. I am on Manage 3d settings under golobal settings to, don't see it.
Gegoben R.A.D. May 22, 2013 @ 12:36pm 
yeah, prefered graphics processor is not there, but I dont see why that would effect activation issues....
Gecks May 22, 2013 @ 1:04pm 
It should be a drop down menu, where it will say auto select. in the drop down menu it'll say High performance Nvidia processor. It worked for me when i changed it
Such Doge™ May 22, 2013 @ 1:14pm 
ok i clicked on the drop down menu but its in global settings? like exactly which one is it like textures or something?
Gecks May 22, 2013 @ 2:07pm 
Alrighty heres a link to a pic of my settings when it has been changed with where it is http://s1279.photobucket.com/user/gecko117/media/7c9f048d-d508-4bdf-8a6b-9c8e43d0d74f_zpsfd257bc2.jpg.html?state=copy
and remember to click apply:P
Such Doge™ May 22, 2013 @ 6:13pm 
Ya my Nvidia doesnt show that bar there, I dont see it
Such Doge™ May 22, 2013 @ 6:16pm 
It actually doesn't have that bar
Gecks May 23, 2013 @ 4:02am 
ah dang well could put the key (if you have one) into origin which worked for me aswell, other than that I have no idea then lol good luck getting it fixed tho:D
Espen May 23, 2013 @ 11:21am 
thanks Gecks that worked for me :D
Buzz May 23, 2013 @ 12:30pm 
Once I changed the name of the .exe file I made a shortcut of that .exe and put it on my dashboard. Then started the game from there. That's the only way it works for me.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Apr 20, 2013 @ 10:50am
Posts: 18