Rome: Total War

Rome: Total War

DeclinedA1 Jul 4, 2013 @ 4:19pm
Rome: Total War failed to find DirectX 9....I have Direct X 11...
Whenever I try to start RTW I get a flashing black screen for a few seconds. An error message then appears saying "Rome Total War failed to find DirectX 9, which is required for the game to run. Please reinstall DirectX."

I updated my video card's drivers, and I cleared out my PC's registry. I downloaded RTW from Steam. I have DirectX 11, which should be compatible with 9. I am playing this on Windows 8.

How can I solve this?
< >
Showing 1-15 of 58 comments
reinstall everything,delete the files on c: and reinstall
DeclinedA1 Jul 4, 2013 @ 4:55pm 
I deleted it from Steam once. But since I have no other options, I will do as you say in hope of resolving the issue.
DeclinedA1 Jul 4, 2013 @ 6:37pm 
The problem persists.
Hendrikus3 Sep 5, 2013 @ 3:26pm 
What I did was go to the preferences.txt file. You can find it at:
C:\Program Files (x86)\Steam\SteamApps\common\Rome Total War Gold\preferences

All I did was go to the line called: AA_Quality_AA: Low
And made it into: AA_Quality_AA: Off

I also tinkered a little with the max screen resolutions in the file, but the game doesn't support my resolution to begin with. In the end I set them all to 1024x768, but it only started worked after I changed the AA_quality line - which I think did it for me.

Hope this works for you!
Cheers,
Last edited by Hendrikus3; Sep 5, 2013 @ 3:27pm
kesmai Sep 6, 2013 @ 2:51pm 
just download the original dx9 from microsoft and install it on your machine.
http://www.microsoft.com/de-de/download/details.aspx?id=35
this is the links to the german version, but it does not matter which languge.
Last edited by kesmai; Sep 6, 2013 @ 2:52pm
blood_eagle_11 Aug 10, 2015 @ 8:33pm 
Hendrikus3, thank you so very much. After playing with everything to try and get RTW to work on Windows 10, your comment about turning off the anti-aliasing was spot on.
Esbian Aug 24, 2015 @ 3:08am 
Originally posted by Hendrikus3:
What I did was go to the preferences.txt file. You can find it at:
C:\Program Files (x86)\Steam\SteamApps\common\Rome Total War Gold\preferences

All I did was go to the line called: AA_Quality_AA: Low
And made it into: AA_Quality_AA: Off

I also tinkered a little with the max screen resolutions in the file, but the game doesn't support my resolution to begin with. In the end I set them all to 1024x768, but it only started worked after I changed the AA_quality line - which I think did it for me.

Hope this works for you!
Cheers,
Yea just do as he said, it worked for me perfectly. Fixed the exact problem stated in the post :D
But for me the AA_Quality_AA: Low, looked like AA_Quality:AA_High for me so if its like that don't worry same thing =)
MyFreshP Aug 29, 2015 @ 3:49am 
Originally posted by Hendrikus3:
What I did was go to the preferences.txt file. You can find it at:
C:\Program Files (x86)\Steam\SteamApps\common\Rome Total War Gold\preferences

All I did was go to the line called: AA_Quality_AA: Low
And made it into: AA_Quality_AA: Off

I also tinkered a little with the max screen resolutions in the file, but the game doesn't support my resolution to begin with. In the end I set them all to 1024x768, but it only started worked after I changed the AA_quality line - which I think did it for me.

Hope this works for you!
Cheers,
Thanks, it's working!

For me the line was AA_Quality: AA_HIGH and I changed it to AA_Quality: AA_OFF.

Note: The same thing works for RTW-BI and RTW-ALX. You just have to edit their preferences.txt. The one of RTW-BI e.g. can be found at:
Steam\SteamApps\common\Rome Total War Gold\bi\preferences
Jocher Aug 31, 2015 @ 3:50pm 
how can i change the quality if i can't even get in the game???
MyFreshP Sep 2, 2015 @ 1:17am 
Originally posted by Jocher:
how can i change the quality if i can't even get in the game???
Like this:
Originally posted by Hendrikus3:
What I did was go to the preferences.txt file. You can find it at:
C:\Program Files (x86)\Steam\SteamApps\common\Rome Total War Gold\preferences

All I did was go to the line called: AA_Quality_AA: Low
And made it into: AA_Quality_AA: Off

I also tinkered a little with the max screen resolutions in the file, but the game doesn't support my resolution to begin with. In the end I set them all to 1024x768, but it only started worked after I changed the AA_quality line - which I think did it for me.

Hope this works for you!
Cheers,
So go to your Steam directory and than to SteamApps\common\Rome Total War Gold\preferences and edit the file preferences.txt. Change the line AA_Quality: AA_LOW (maybe it is AA_HIGH) to AA_Quality: AA_OFF
Wolf_1_08 Nov 11, 2015 @ 4:42pm 
I just wanted to comment to add that I was experiencing a very similar issue, the only differences being that I am not sure if I have DirectX 11, and I am playing on Windows 10. Despite those differences, the solution about going into the preferences.txt file worked great! Just wanted to drop by and say thank you!
ptrckloney Nov 11, 2015 @ 5:43pm 
Originally posted by Hendrikus3:
What I did was go to the preferences.txt file. You can find it at:
C:\Program Files (x86)\Steam\SteamApps\common\Rome Total War Gold\preferences

All I did was go to the line called: AA_Quality_AA: Low
And made it into: AA_Quality_AA: Off

I also tinkered a little with the max screen resolutions in the file, but the game doesn't support my resolution to begin with. In the end I set them all to 1024x768, but it only started worked after I changed the AA_quality line - which I think did it for me.

Hope this works for you!
Cheers,

ah, thankyou this worked perfectly.
ryanhicks63 Nov 19, 2015 @ 3:31pm 
Originally posted by Hendrikus3:
What I did was go to the preferences.txt file. You can find it at:
C:\Program Files (x86)\Steam\SteamApps\common\Rome Total War Gold\preferences

All I did was go to the line called: AA_Quality_AA: Low
And made it into: AA_Quality_AA: Off

I also tinkered a little with the max screen resolutions in the file, but the game doesn't support my resolution to begin with. In the end I set them all to 1024x768, but it only started worked after I changed the AA_quality line - which I think did it for me.

Hope this works for you!
Cheers,

bump. Worked for me perfectly. Thank you so much
Jaskolka Nov 20, 2015 @ 9:13pm 
Yes changing the AA_Quality_AA usually works :3
Can confirm: in windows 10, changing the line
AA_Quality:AA_High
to
AA_Quality:AA_Off
immediately fixed the problem for me
< >
Showing 1-15 of 58 comments
Per page: 15 30 50