Rome: Total War

Rome: Total War

HazardHawk Jun 16, 2015 @ 2:20pm
Windows 10 and Rome
If you have a working copy of Rome and upgrade, it will still work.

If you have windows 10 and are working from clean install...

Install Rome... It will not load, do not worry...

Browse into Rome folder, set compatibility for Rome and BI to XP Service Pack 2

Leave the above window open and open file explorer to browse into C:/Windows/System32

Scroll down and find your d3dx9_24 through d3dx9_43 files, highlight, right click, copy, paste into Rome main folder.

Now, what you do not have and need is the contents of a Rome Preferences Folder and Rome cannot start to generate these. Message me or another friend with a working copy of Rome and get us to zip up the prferences folder and email it to you... Put it in place and you are working!
Last edited by HazardHawk; Jun 16, 2015 @ 2:20pm
< >
Showing 1-15 of 81 comments
shunwick Jun 16, 2015 @ 3:44pm 
Originally posted by HazardHawk:
If you have a working copy of Rome and upgrade, it will still work.

So if I upgrade to Windows 10, my current installation of Rome Total War will work ok without the need to do anything at all? Have I understood this correctly?

Is the same true for Alexander?
Last edited by shunwick; Jun 16, 2015 @ 3:51pm
HazardHawk Jun 16, 2015 @ 4:29pm 
I have only been working on trying to find the errors others have been reporting for Rome and Windows 10. My Alexander still works. It took me awhile to figure out how to make Rome NOT to work so I could find the problems. It worked perfectly for 8 clean installs before it would not work.

Not everyone is going to have issues. In upgrading, both with and without the directx 9 files placed locally it works vanilla after upgrade 10 for 10 each for me. I suggest putting them in place so the windows upgrade will register their locations anyways because there are people reporting without they cannot get a resolution to register crashing back to desktop.

I also have reports of Windows 10 changing defult programs like video playback to the internal windows video player and this will crash older games with videos like StarCraft and Rome and between.

Disk version Heroes of Might and Magic 3 which is directX 8 works perfectly.

Act of War which was video crashing under Vista through 8.1 no longer has issues playing.

The graphics are too simple to be even decent, but even Total Annihilation loads and plays as do Shogun and Medieval Total War.
shunwick Jun 16, 2015 @ 4:35pm 
Thanks for that. I appreciate the work you have put in.
HazardHawk Jun 16, 2015 @ 7:27pm 
Two quick notes... To get around the video player, open windows media player and reset it to default. I loaded Klite Codec pack and use Media Center Classic, but just changing the defalt programs for video to something known fixes that issue.

The last is sound. Windows 10 does not emulate so the rear or surround speakers are dead for all practical purposes for both 5.1 and 7.1 unless the files being played is native 5.1 or 7.1 AND your play medium actually handles 5.1 or 7.1 sound processing. Front, center, and sub all work perfectly for 3.1.
ChipperDan Jun 21, 2015 @ 6:31am 
Hi Hazard Hawk, I wasnt able to find an option to message you, but have done all the steps apart from the preferences folder, any chance you could drop me a message or send me the preferences folder,

Thanks,

dan
Last edited by ChipperDan; Jun 21, 2015 @ 6:34am
HazardHawk Jun 21, 2015 @ 9:50am 
Guessing you have 10 and just bought Rome... Sent you message...
HazardHawk Jun 21, 2015 @ 10:13am 
Listen up folks... If you install Rome to Windows 10, it will not generate the contents of the preferences folder and this is why it is crashing and not starting. I am passing out a rar copy of my preferences folder as needed. The last Windows 10 update cleared the directX problem so all that is needed are these files to drop into place and Rome runs as well as it did back in the day!

You can get them from any friend who has Rome installed. Have them browse to their Rome Local Files, attach the preferences folder to an email and send it to you. It is VERY small so do not worry. There are no active files and if need be to make you feel safe, set the folder and its contents to read only, but be aware you will have to change any settings manually in the preferences.txt using notepad if you do.

EDIT: Please do not put email addresses here. If you do not have a friend that can help you, add me to friends, as soon as you see I accepted, send me a message asking for preferences folder and give me an email address. If someone wants to host their zipped up preferences folder on a download server, feel free to do so and share the link.

EDIT: #2 Files uploaded here... http://www.twcenter.net/forums/showthread.php?691946-Windows-10-(moderator-take-notice-please)
Last edited by HazardHawk; Jun 21, 2015 @ 11:03am
KingBen1223 Aug 15, 2015 @ 6:41pm 
Hi Hazard Hawk,

I have done all the required steps apart from the preferences folder, so could you please message me the preferences folder?

Thanks,

KingBen1223
HazardHawk Aug 15, 2015 @ 6:44pm 
http://www.twcenter.net/forums/showthread.php?691946-Windows-10-(moderator-take-notice-please)

Go to TWCenter. If you do not have an account, it is free. Just grab and drop into place.
Last edited by HazardHawk; Aug 15, 2015 @ 6:45pm
SlyDessertFox Aug 15, 2015 @ 11:23pm 
The only problem I had with starting Rome with Windows 10 was I had to go into the files and turn anti-aliasing off.
wakkawakka Aug 15, 2015 @ 11:31pm 
Please help me... I'm getting desperate. I've tried your steps above - downloading your preferences and adding it to my Rome file. Nothing has helped! The farthest I can get is to the home screen. When I click "Play Rome: Total War", it asks me for permission and then nothing. I have disks from a long time ago, did not download from Steam. I got a new PC and I installed Rome AFTER upgrading to Windows 10. I just want to play my favorite game again!
demetriusmontoya Aug 16, 2015 @ 8:03am 
I followed the steps above, then updated my drivers. This worked for me, make sure you don't have wide screen enabled if you don't have a widescreen. Hope this helps as RTW is my favorite game. :steamhappy:
reime59 Aug 19, 2015 @ 7:06pm 
I have copy and paste it dx9 to 24 thru dx9 43 into romen total war is located,but fails to reponse or just crashes
reime59 Aug 19, 2015 @ 7:09pm 
where is this wide screen?

California Aug 19, 2015 @ 7:10pm 
Problem For Me Is Preformance is terrible. 20-30 fps a second. It used to be a solid 60fps. Any fix?
< >
Showing 1-15 of 81 comments
Per page: 15 30 50

Date Posted: Jun 16, 2015 @ 2:20pm
Posts: 81