jsdratm Oct 29, 2012 @ 7:01pm
Poor Performance?
Is anyone else having very bad performance in this game? It looks like a fun game, but I am getting very bad stuttering, even at 800x600 resolution and I have a 560 Ti.
Showing 1-13 of 13 comments
< >
SnarKs Oct 29, 2012 @ 7:44pm 
yeah. game has issues. FPS goes to a crawl after a few minutes of gameplay.
Dr.Wahwee Oct 29, 2012 @ 7:48pm 
Refer to this thread: http://forums.steampowered.com/forums/showthread.php?t=1279444 if it helps.

I had terrible frame rate issues, I used this fix and the frame rate issue got fixed. Hope it helps!
jsdratm Oct 29, 2012 @ 8:14pm 
Dr. Wahwee nailed it, thanks for the help! Now I can play at max settings no problem. :D
SnarKs Oct 29, 2012 @ 8:28pm 
Yeah thats unrelated to my issue.

I seem to have fixed it by enabling windows XP compatability and running the game as administrator.


Meh, I dont know why i even said that. I have a G9 mouse. And that fix works. I even remember it from when I was playing fear a while ago now.
Last edited by SnarKs; Oct 29, 2012 @ 9:01pm
Adam Oct 30, 2012 @ 6:56pm 
OMG! Thanks guys for this, i was wondering why the hell it was so laggy. Now i can play it on max with 100FPS, YAY! Again thanks :P!!!!!!
♫TGC> The Games Collector Dec 3, 2012 @ 10:44am 
I had a horrible lag on this game too.
I didn`t really want to go trough the hassle of disabling and enabling stuff in device manager.
So I disabled setpoint and other logitech applications before playing; lag`s gone.

:/ really weird that keyboard and mouse are killing the framerates on this one. You`d expect the graphics card to be the culprit...
Si Cwan Dec 23, 2012 @ 12:00am 
no go for me. did everything he said in the other post, and even shutdown setpoint and my keyboard software.. still feels like a slide show
truehorror Dec 23, 2012 @ 12:19am 
Weird, I didnt have to fix anything and completed the game didnt get any fps drops. And my pc isnt all that great anymore, for example my gpu is a single ati 4890
Si Cwan Dec 23, 2012 @ 12:24am 
I finally figured out what was causing it for me... RAPTR
and anyone know why the game is ver 1.0.314 and the retail one is 1.0.320 ?
Dark Kobra Dec 26, 2012 @ 6:07am 
Same for me. I'm on an i7, 16GB Ram and a GTX 680 and drops to about 20 fps..... will try that fix and see how it goes
Apolonio the Walrus Guy Dec 30, 2012 @ 4:16pm 
I ran it at max graphics with my Nvidia 9400 GT with no problems
krashd Jan 31, 2014 @ 4:32pm 
That's because an Amiga could play Condemned, the problem wasn't performance related, it was a Logitech/HID-device/refresh bug thing, Monolith puts it in all of their games, if you have Logitech hardware you get 5fps. Took me 17 months to complete F.E.A.R.
TIWS 20 hours ago 
Originally posted by Si Cwan:
I finally figured out what was causing it for me... RAPTR

Same here -- I don't have any Logitech device to begin with. Launching the game outside Raptr did the trick for me. Nostalgia interruption FTL. Ha.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50