Angus Oct 29, 2013 @ 1:02pm
Lag issues
it was fine until i got into the first investgation then just started chugging along, i have a 2.5 ghz dual core and 8 gigs ram. I can run dishonored and borderlands 2 but somehow this game has serious lag issues, i even tried putting everything on minimum, why is this happening????
Showing 1-13 of 13 comments
< >
GiroMindTricks Oct 30, 2013 @ 6:26am 
If you're running an nvidia card change the Power Management mode in the nvidia control panel to maximum for this game. That fixed it for me.
ThresheR 593 Nov 1, 2013 @ 1:09pm 
Originally posted by GiroMindTricks:
If you're running an nvidia card change the Power Management mode in the nvidia control panel to maximum for this game. That fixed it for me.
Thanks man this worked for me also.
starshipwaters Nov 7, 2013 @ 12:19pm 
Originally posted by GiroMindTricks:
If you're running an nvidia card change the Power Management mode in the nvidia control panel to maximum for this game. That fixed it for me.
Fixed things up for me too! Thanks a lot dude.
rajkosto Dec 25, 2013 @ 1:19am 
I also had to do this: http://i.imgur.com/lHncTzK.png
Just disabling the Human Interface Devices service in services.msc didn't do the trick
Same fix applies for FEAR1 and it's expansions
Notice that you only need to disable the devices starting with HID *
cybertrance Jan 1 @ 5:13pm 
I have same troubles but with an ATI card, the game gets nearly unplayable later on when to many things happen ingame at same time on the monitor

Originally posted by rajkosto:
I also had to do this: http://i.imgur.com/lHncTzK.png
Just disabling the Human Interface Devices service in services.msc didn't do the trick
Same fix applies for FEAR1 and it's expansions
Notice that you only need to disable the devices starting with HID *

i cant do this fix, because my keyboard itself (logitech G19) is an HID device;
any other suggestions?
Last edited by cybertrance; Jan 1 @ 5:14pm
Bacon Jan 18 @ 12:33pm 
Originally posted by cybertrance:
I have same troubles but with an ATI card, the game gets nearly unplayable later on when to many things happen ingame at same time on the monitor

Originally posted by rajkosto:
I also had to do this: http://i.imgur.com/lHncTzK.png
Just disabling the Human Interface Devices service in services.msc didn't do the trick
Same fix applies for FEAR1 and it's expansions
Notice that you only need to disable the devices starting with HID *

i cant do this fix, because my keyboard itself (logitech G19) is an HID device;
any other suggestions?

I also have the same problem as you. I just cracked the ♥♥♥♥♥ and uninstalled the game.
I wasn't able to find anything at the time to get it working. I read it had something to do with logitech keyboard and/or mouse (which I have both). I couldn't be bothered or couldnt at the time but if you have a spare non logitech keyboard (and or mouse if you also use a logitech mouse) try that and see if it works.
kushziller Jan 28 @ 12:42am 
Originally posted by cybertrance:
i cant do this fix, because my keyboard itself (logitech G19) is an HID device;
any other suggestions?

I'm using a Logitech G19 and it works fine. Only disable the entries with HID- at the start.
Not the USB Input Device entries.
shaunabels Mar 5 @ 10:45am 
Originally posted by rajkosto:
I also had to do this: http://i.imgur.com/lHncTzK.png
Just disabling the Human Interface Devices service in services.msc didn't do the trick
Same fix applies for FEAR1 and it's expansions
Notice that you only need to disable the devices starting with HID *

Awesome. I was beginning to think this game was just almost unplayable...but so many people say how good it is. I knew there had to be an issue as I have no issues playing many other games. This worked for me (services.msc route did not for me either) and now this game is actually pretty sweet. Much improved and fluid movement and I can actually hold my own in melee. Thanks for the post!

Edit: Oh, and I don't use the G series logitech either. I'm on a HP Pavilion laptop with AMD A6 and using a logitech M325 mouse. Apparently their engines just hate anything logitech...
Last edited by shaunabels; Mar 5 @ 10:47am
Originally posted by GiroMindTricks:
If you're running an nvidia card change the Power Management mode in the nvidia control panel to maximum for this game. That fixed it for me.

This also worked for me! Thanks Man! Loved this game on Xbox and now I can finally enjoy it on PC. Cheers!!! =D
DeViLzzz Apr 29 @ 3:54pm 
Lag issues? I think you mean frame rate issues. Anyway I checked my settings and saw that "Prefer maximum performance" was not selected in the power management mode in Nvidia Control Panel program settings for this game and so maybe this will give me smoother performance with this game as when playing despite having good hardware it was kind of choppy in terms of performance but this really likely is just something with the quality of the game and the way it was made. I hope the recommendation made to have this game run better works but I am not counting on it.

As for other things that may help what about triple buffering?

Update:

I tried the game with "Prefer maximum performance" turned on and it made no positive difference. In fact it may have made it worse. As for trying triple buffering I didn't get to that yet but will later and will update the update. :)
Last edited by DeViLzzz; Apr 29 @ 4:15pm
DjShIzz (Got Games To Trade?) May 22 @ 11:55pm 
For some reason now my game will run beautifuly after loading a save at 60fps but then literally everytime like clockwork it would slowly drop to 30fps only and stop. I did the whole "Maximum Peformance" for my NVIDIA and that is what made this game playable for me, but now it drops fps everytime slowly and gradually till it gets to 30fps. weird.

Any insight my friends?
Finley May 25 @ 9:23am 
Originally posted by DjShIzz:
For some reason now my game will run beautifuly after loading a save at 60fps but then literally everytime like clockwork it would slowly drop to 30fps only and stop. I did the whole "Maximum Peformance" for my NVIDIA and that is what made this game playable for me, but now it drops fps everytime slowly and gradually till it gets to 30fps. weird.

Any insight my friends?

Yeah, this is a standard issue fixable by disabling all HID-compliant devices in Device Manager. See the post above for more directions.
c5 May 29 @ 7:00am 
After I'm done playing, should I re-enable the HID devices?
Showing 1-13 of 13 comments
< >
Per page: 15 30 50