TnT4blast Apr 13 @ 10:44am
Very low fps
Hey guys,

Im getting very low fps no matter that settings i use.
I disabled all HID devices but that didnt help, also i dont have any logitech software on my pc.
Can someone help me fix this madness?

My rig:
i5 2500k
HD 7970Ghz Club3D RoyalAce
G.Skill 8GB DDR3 1600MHz

Greetings, TnT4blast
Showing 1-15 of 21 comments
< >
I found my fix for Low FPS for this Game in another Thread. IF you have a Nvidia Graphics Card Than go to the control panel for this game and change the "Power Management Mode" to MAXIMUM. Hit Apply and then try running it and That did it for me!

Try it out and let me know!! =D
TnT4blast Apr 29 @ 7:03am 
I have a HD 7970 = AMD videocard so that doesnt work.
DeViLzzz Apr 29 @ 4:17pm 
DjShizz your fix didn't do it for me. I am going to get a frame counter or whatever later to see what it says this game plays at. Anyway it definitely isn't smooth that is for sure and I am running this with a GTX 670 and an i5 2500k and it should have no problem running it even if I max the settings.
OddJob May 5 @ 8:47pm 
This game seems to have similar issues to what are experienced in FEAR; disabling HID (Logitech Mouse) devices increased FPS from ~ 20 to ~ 225.
UberNoodle Jun 24 @ 7:39am 
Search the Steam forums for FEAR for "disable HID". It's a problem with the drivers, usually produced by Logitech but not necessarily, which the game engine doesn't appreciate.
roi.yog Jun 24 @ 10:54am 
Simply go into the Start menu and right-click "Computer", choose "Manage".

From there, go to "Device Manager" and choose "Human Interface Devices".

To get the best performance, you are going to want to disable all "HID-Compliant Device", you should not need to disable ANYTHING else.

That worked for me
Last edited by roi.yog; Jun 24 @ 10:55am
=AxA= Valkrex Jun 27 @ 6:55pm 
Same issue here, would disabling the HID's disable my mouse though? And when I'm done does it re-enable them automaically when I restart my PC or do I have to go back and enable them manually?
Weedeater Jun 28 @ 3:08am 
Usually your mouse/keyboard is recognized as such, separately, as a USB Mouse in the same driver subsection in System. Disabling just the drivers that start with "HID" most likely will not turn off your mouse.

I also do not think that having those drivers disabled really does much outside of the game. You could try to use the computer for a couple hours/days with them disabled and if you don't notice any issues - just forget about it.

That being said - disabling the HID devices helped my computer run this game. Before that I was getting horrific framerates (like 5-10 FPS), now it runs everything like butter.
PRESS F TO PAY RESPECTS Aug 8 @ 3:31pm 
What fixed it for me was disabling that AMD Gaming Evolved program. I was getting 35fps no matter the setting, now it's over 100. Try that if you're still having issues with it.
DentalAppointment Sep 13 @ 9:57am 
Excuse the exclamation, but for f-s sake people, the OP clearly stated that shutting off HID didn't solve the problem, as well as that he doesn't have a Logitech mouse.
kokootto Sep 13 @ 5:18pm 
Last edited by kokootto; Sep 13 @ 5:18pm
Ramo$ Sep 18 @ 1:29pm 
160 fps on ultra, get_rekt
DentalAppointment Sep 21 @ 6:10pm 
Okay, I don't know how this happened but I take my previous commnet back - it seems I stumbled on a weird solution to the mouse issue. I thought it wasn't my mouse (b.c. people were saying it was a logitech mouse issue) - but now it's possible it may have been the mouse.

When I would go turn off HID in control panel it froze my mouse (an E-Blue Cobra). Same thing for a 360 controller (which Condemned doesn't seem to properly support anyway), and of course I can't play the game on a touchpad. What I did was not to touch HID but unplug the mouse, then plug it in *after* launching the game. Don't know how this worked but for the first time I loaded a saved game and it automatically had bumped the res & settings to max, and FPS was normal.

If this ameliorates the slow-down & FPS issues for anyone else I'd be curious to know.
TnT4blast Sep 22 @ 9:16am 
Hey guys,

Im sorry that i didnt say anything.
but i bought a logitech g502 proteus core, and then disabled the HID stuff.
It works now.
ragequit Sep 30 @ 1:24pm 
same problem here, i have several logitech hid's... i noticed when i unplug my mouse (g500) and then replug it while being in game fixes the issue for some time (5-10min maybe) and then the fps gets worse and worse again until its basically unplayable.

edit:
i just found out that disabling the steam overlay from the steam game properties (rmb on the game in your library) fixes the issue for me.
Last edited by ragequit; Sep 30 @ 1:49pm
Showing 1-15 of 21 comments
< >
Per page: 15 30 50