Post Mortem > General Discussions > Topic Details
Asan.par2 Apr 23, 2013 @ 5:05pm
How to play this game in windows mode?
How to play this game in windows mode?..
Showing 1-15 of 15 comments
< >
RollingSun2000 Apr 25, 2013 @ 5:29pm 
I had the same problem. I hated how my widescreen was stretching out the dispaly.

This solution is actually for Syberia, but it is made by the same developers as Post Mortem and works the same way.

Originally posted by drennan:
Create a file named player.ini in your Syberia folder with the contents:

800 600 16 0 BaseCMO.cmo

The only value you should ever edit in the ini is the 4th integer (0=windowed mode, 1=full-screen mode). The first three values (Horizontal resolution, vertical resolution, bit depth) are hardcoded so they will be ignored anyway, the last one (name of the main game file) should be left alone.



Once again, 0=windowed mode, 1=full-screen mode, leave the second parameter alone.





For anyone who doesn’t know how to create the Player.ini file:

1) Open Notepad on your computer.
2) Paste the specified line of code into it.

800 600 16 0 BaseCMO.cmo

3) click “save as.”
4) before naming the file, change “save as type” option to “All Files.”
5) Name the file player.ini

Now you can save the file. Make sure to save it into (or drop into) your Post Mortem folder
I am using Windows 7 64bit, so my location looks like
C:\Program Files (x86)\Steam\steamapps\common\Post Mortem


I know this works because I'm using it myself. I haven’t played long enough to experience errors though.

Happy gaming. :)

Last edited by RollingSun2000; Apr 26, 2013 @ 9:52am
Mysterious Stranger Apr 28, 2013 @ 9:49am 
thanks!
Mysterious Stranger Apr 28, 2013 @ 10:12am 
This REALLY works, RollingSun2000
and your How to create the Player.ini file step-by-step instructions
are perfect! for beginners. (sadly, I know n2n about computing, but sbs, am learning ...)

off2play in windowed mode, thanks2you :)
Cheers!
Last edited by Mysterious Stranger; Apr 28, 2013 @ 10:14am
Asan.par2 Apr 28, 2013 @ 4:01pm 
Thank very much.I get it..
Can you solve the same question in Still Life1&2 ? those two game are fullscreen too :(
RollingSun2000 Apr 28, 2013 @ 5:13pm 
?? - I'm glad I could help. After a bit of experimenting with the code, I think the file only needed 0 BaseCMO.cmo
It doesn't seem to be a perfect fix (for me, my regular mouse cursor was still visible) but it does the job.

par2 - Did you try "copy and paste" the player.ini file into your Still Life folders? (They are also made by the same developers).
I don't own those games (yet) so I can't test it myself.
Have you tried Alt+Enter? I have a feeling it won't work.
Have you looked inside the Still Life 1&2 folders? There might be an exe application that allows you to adjust settings like window mode.
I'm sorry I can't give much help with those games.
Last edited by RollingSun2000; Apr 28, 2013 @ 5:14pm
ϟ Ericz Apr 28, 2013 @ 6:23pm 
I try it and works, but i don't really know what's worst: stretching display or the small window. lol
That's sad... not even a fullscreen with black sidebars.

Ok, is a 2001 game, but i think they may code a fix, or at least insert this information on system requirements or something. "All" screens are widescreen now, so you can't play the game how he should be.

I'll prolly play on stretched widescreen, but i'm being tired of that type of things... You buy a thing and them you have to run like crazy over the internet to fix them... that's absurd. :(
RollingSun2000 Apr 28, 2013 @ 6:44pm 
@ ericcoutinho
I have found that playing the game on a second monitor helps fix the aspect ratio (black bars on the side). I'm using a laptop, but I connect it to my TV using a HDMI cable and that seems to fix the display. The resolution changes on everything and that seems to fix the game when displayed on my TV.

I think there is something in the settings for Nvidia graphic cards, but I'm using an ATI Mobility Radeon and I can't seem to find similar setting in my Catalyst Control Center.

Someone was having aspect ratio problems with the game Resonance. This was his solution:

Originally posted by Saftle:

It was a misconfiguration in the Nvidia Control Panel. I did the following to get it working:

Under Display - Adjust desktop size and position - Scaling (Tab). Changed it to Aspect ratio, Perform Scaling on: GPU, and Resolution to my desktop resolution.

I don't know if that will help anyone here, but it might help someone.
Last edited by RollingSun2000; Apr 28, 2013 @ 7:15pm
ϟ Ericz Apr 28, 2013 @ 7:23pm 
Thank you for help, but it didn't solve in my case, cause my second monitor is widescreen too, and my gpu an intel. =/

I'm trying to play for about 2 hours.... aaaarghh! :P
RollingSun2000 Apr 28, 2013 @ 7:53pm 
I'm a little confused. Are you sure your GPU is intel?? That sounds more like your processor (CPU).
You should either have Nvidia or ATI.

I am trying to search ways to adjust the aspect ratio for my laptop, but it seems the settings in my AMD Catalyst Control Center are not the typical kind one would normally have.

For Nvidia Control Panel, use the advice above.

For AMD Catalyst Control Center (that is what I have), you can try this:
http://support.amd.com/us/kbarticles/Pages/UnableToSetGPUScaling.aspx

or this: (this one makes more sense).
http://techreport.com/forums/viewtopic.php?f=3&t=68072

(sorry for providing English links).

Even though you might not have either of those control centers, something tells me that the "Maintain" or "Preserve" Aspect Ratio settings are found on all computers in some form.
It seems you will have to lower your resolution to something "not widescreen" before you can select the Aspect Ratio settings.
If that doesn't help (or stay applied), you might be able to change the settings from "full screen" to "centered." It will be pretty much the same size as playing in windowed mode, but it will put black boarders around the entire screen (instead of just at the sides).
Last edited by RollingSun2000; Apr 28, 2013 @ 8:01pm
Asan.par2 Apr 29, 2013 @ 1:52am 
I try "copy and paste" the player.ini file into Still Life folders.but useless :(
Alt+Enter.... useless too....
But.. thx your suggestion..
RollingSun2000 Apr 29, 2013 @ 4:12am 
par2 & ericcoutinho

Use Google to search for information (in your native language) for adjusting Aspect Ratio on your computer.

You should have software or drivers that came with your GPU for adjusting the settings.
What you need to change is your Image Scaling option.

I think it is safe to say that right now your Image Scaling is set to "fullscreen." You need to change it to Maintain (or Preserve) Aspect Ratio or "Center."

Sorry I can't be of more help. I think the language barrier is causing more confusion than it should.
Last edited by RollingSun2000; Apr 29, 2013 @ 4:18am
ϟ Ericz Apr 29, 2013 @ 6:01am 
My GPU is an integrated Intel, HD3000, and like NVidia it comes with a settings software. This software don't let me change aspect ratio, but it is by default "mantain aspect ratio", relative to dispositive.

I just think there's something in the code that just stretch the window, whatever the resolution is, so if you have a monitor on a 4:3 scale, the game windows will scale without problems, because it is the same scale.

Thank you very much for your help, and good-will, i appreciate it.
I think i'll just play with the more confortable option.

ps: Maybe you don't understand so good what i write, cause i'm really bad at it, but reading i'm not so bad. :D
RollingSun2000 Apr 29, 2013 @ 11:28am 
I understand now. I never heard of an integrated Intel GPU before (I don't know as much about computers as I would like). Is it good? Nvidia and ATI seem to be the industry standard.

I would disagree about there being a code in the game forcing it to stretch out to fill the screen. I mentioned before that the resolution on my laptop changes for me when I connect it to my TV using a HDMI cable. My TV is a normal HD widescreen TV (1280x720). Nothing fancy other than the HD and connection options. When I play the game through my TV, the black bars are added to the sides. This would mean the Maintain Aspect Ratio works properly when displayed on my TV.

Have you tried using your second monitor as your primary? If you press the Windows Key+P you should be able to select "Projector Only." That might force your computer to use the Maintain Aspect Ratio properly - That might be what is happening when I use my TV.

That is strange that maintain Aspect Ratio is set as default but it is not working. What is "relative to dispositive?" Are you able to tweak that setting separately?
Are the Image Scaling options greyed out (preventing you from changing it)?
I would suggest looking at the display properties / Image Scaling options in you Intel control center again and experiment around.

If the options are greyed out, you might need to change your resolution to something that isn't widescreen first, then look for the Image Scale option in the Intel GPU software.
Once you have an option selected you can apply it and then change your resolution back to normal.

On my laptop, "Maintain Aspect Ratio" fails to stay applied, but "Centered" works.
Centered is no different then Windowed Mode, but it is a lot nicer to look at (it creates black boarders to fill the screen around the game). I mentioned this before, but I feel you may be discouraged because it is not the solution you were hoping for.

I wish I could be of more help. Good luck.
Last edited by RollingSun2000; Apr 29, 2013 @ 12:19pm
ϟ Ericz Apr 29, 2013 @ 4:03pm 
We have a lot of notebooks with intel integrated graphics here (on Brazil). They're on the middle of standard and gaming notebooks. HD3000 let me play almost all recent games on low graphics at least. It is pretty good, in front of another integrated graphics.

I try a lot of things, including setting monitor as primary.
Finally, i found that i can manually (painfully) change the monitor aspect ratio, and after a while i made it. Now i have a centered 1024x768 game area. The image still a little messy, but that is because the original resolution of the game is 800x600.

If the options are greyed out, you might need to change your resolution to something that isn't widescreen first, then look for the Image Scale option in the Intel GPU software.
Once you have an option selected you can apply it and then change your resolution back to normal.
That is true.

Well, many thanks. Now i can play it better. :)
Whiplash Apr 30, 2013 @ 11:12pm 
This worked for me. Can now play in full screen, correct aspect ratio with black borders centred screen. Thanks.
Originally posted by RollingSun2000:
@ ericcoutinho
I have found that playing the game on a second monitor helps fix the aspect ratio (black bars on the side). I'm using a laptop, but I connect it to my TV using a HDMI cable and that seems to fix the display. The resolution changes on everything and that seems to fix the game when displayed on my TV.

I think there is something in the settings for Nvidia graphic cards, but I'm using an ATI Mobility Radeon and I can't seem to find similar setting in my Catalyst Control Center.

Someone was having aspect ratio problems with the game Resonance. This was his solution:

Originally posted by Saftle:

It was a misconfiguration in the Nvidia Control Panel. I did the following to get it working:

Under Display - Adjust desktop size and position - Scaling (Tab). Changed it to Aspect ratio, Perform Scaling on: GPU, and Resolution to my desktop resolution.

I don't know if that will help anyone here, but it might help someone.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50