Syberia > General Discussions > Topic Details
cpants Dec 10, 2013 @ 12:26pm
3d accelerator error
Syberia 2 works fine, but when I try to play Syberia it gives me a 3d accelerator error. It looks like there is a way to fix this if using Windows 7 but I'm on 8.1. Any solutions for me?
Showing 1-9 of 9 comments
< >
Faxmaister Dec 20, 2013 @ 1:14pm 
Same issue on Win 8.1. I solved the problem changing the compatibility settings of the game executable "Games.exe" in this way:
- Check on Execute the application in compatibility mode for Windows 98/Me
- Check on Reduced color mode 256bit
- Check on run as administrator
cpants Dec 20, 2013 @ 1:29pm 
Thanks it worked. Much obliged Faxmaister
danhm001 Dec 20, 2013 @ 10:00pm 
thanks
nikjson Jan 3 @ 7:12am 
The above solution does not seem to work for me. I've set either and both of the executables to the recommended compatibility-settings, without any change in my error message. The message is a normal windows message-box.

*******
Syberia - Initialization error
No available 3D accelerator
Either your 3D card does not have the required functions for the game or there has been an error and you should reboot your computer.
*******

I run Win8 on an Intel i5-4670k with 8GB, using a GeForce GTX 560 Ti on driver 331.82, making the above somewhat cryptic. (What on earth would Syberia do with a 3D-accelerator anyway?)

Am I missing something? Are there better drivers? (Perhaps backlevel?) Is there some sort of compatibility-pack for Win8 that will allow disused function-calls? Have I angered Kibo by not shriving the Turnip of Obscure Wisdom in the proscribed manner?

Help?
CarlinFan Jan 21 @ 7:25am 
Originally posted by Faxmaister:
Same issue on Win 8.1. I solved the problem changing the compatibility settings of the game executable "Games.exe" in this way:
- Check on Execute the application in compatibility mode for Windows 98/Me
- Check on Reduced color mode 256bit
- Check on run as administrator

you call 256bit color reduced? ;)
hunter(EDL) Jan 22 @ 6:15am 
go to my advice that i gave look in forum list
cpants Jan 22 @ 6:19am 
reducing the color worked/ Thanks Faxmaister
AlienSoul Feb 22 @ 5:32am 
This worked for me but only on 8 bit color.
cpants Feb 22 @ 10:03am 
That's exactly what I did from an earlier tip and it worked but thanks for advice again anywayz
Showing 1-9 of 9 comments
< >
Per page: 15 30 50