Syberia > General Discussions > Topic Details
Just a Potato Jul 22 @ 8:29am
The 3D Rendering Engine Could Not Be İnitialized
i bought this game for getting trading cards :D, but i cant open it . İt is always giving the same error . İ search at the internet, but couldnt find anyting . same as here ? tell me if you have the same problem .
Showing 1-10 of 10 comments
< >
Meridian4  [developer] Jul 22 @ 8:55am 
Sound like a DirectX issue. Try downloading DX9 files. This will not erase your current DX version only adds to it.

http://www.microsoft.com/en-ca/download/details.aspx?id=34429

If this doesn't work please email our support department at support@meridian4.com and include your dxdiag file.
Just a Potato Jul 22 @ 9:06am 
it isnt working i tried but still giving me the same error
Winchester 73 Jul 22 @ 1:36pm 
Sounds like you cant answer the question. On Windows 8.1 x64 this wont work, because i dont use Win 98, ME, XP, 2000 or Server 2003. And DX9.x is included on Windows 8.1. Why Syberia 2 works fine?
AmazingRevenge14507 Jul 23 @ 12:01am 
Why if you know that people with windows 8 or 8.1 have problems with the game don't you patch the game? I have windows 8 and no matter how hard i try i can't get it to work! Neither syberia 1 and 2
Just a Potato Jul 23 @ 4:29am 
i have windows 7 and i cant open it , and i dont have 64 bit so that s why i couldnt open it but iam fine because i have notebook so can play at here :D

Winchester 73 Jul 23 @ 11:16am 
Just edit the Game.exe. Run as admin, Compatibility Mode XP SP2, change to 8bit color, resolution 640x480, DPI scale and manually download and install the DX9.0c Full Package, not the Webinstaller. Works on Windows 8.1 x64 and AMD R9 270X.
Last edited by Winchester 73; Jul 23 @ 11:17am
ronhawkerazm Jul 26 @ 6:00pm 
Tried those settings but it still comes up with no 3d accelerator available error. Syberia II works fine.
ronhawkerazm Jul 29 @ 9:39am 
Doing the settings to both syberia.exe and game.exe made the difference. It now works in Windows 8.1
Vindeb Aug 3 @ 5:22pm 
Originally posted by ronhawkerazm:
Doing the settings to both syberia.exe and game.exe made the difference. It now works in Windows 8.1

This worked for me as well. Thanks!
Showing 1-10 of 10 comments
< >
Per page: 15 30 50