Fatal Oct 20, 2013 @ 1:11pm
how do you fix the mouse lag?
Cursor is laggy. 60fps so that isn't it.
Showing 1-4 of 4 comments
< >
LarsenB Oct 20, 2013 @ 2:54pm 
For my Logitech mouse I was able to fix that by by reducing the speed of updates/sec (not the DPI settings, it's another value labelled, under the logitech software/advanced gaming settings page, "report per seconds"... ); it was set to 1000, toned it down to 500, mouse is now smoother

It might be also tied to the "Enhance pointer precision" setting found in the standard mouse control panel application... try both the ON and OFF setting
Last edited by LarsenB; Oct 20, 2013 @ 2:55pm
Lelouch vi Britannia Nov 8, 2013 @ 8:11am 
Originally posted by LarsenB:
For my Logitech mouse I was able to fix that by by reducing the speed of updates/sec (not the DPI settings, it's another value labelled, under the logitech software/advanced gaming settings page, "report per seconds"... ); it was set to 1000, toned it down to 500, mouse is now smoother

It might be also tied to the "Enhance pointer precision" setting found in the standard mouse control panel application... try both the ON and OFF setting

Thanks for the tip!
posfan12 Apr 28 @ 9:03pm 
I have a GE 97986 rvS3 mouse. It's not a gaming mouse. Windows 7 detects it as a "Microsoft PS/2" mouse. I'm still getting the lag even though the "Enhance pointer precision" setting is disabled. Any tips?
The Blob May 7 @ 4:01am 
You should be able to fix it even on standard drivers. To do so go to control panel, double-click mouse, select the "Hardware" tab and choose "Properties" button. Select the "Advanced Settings" tab, and lower the "Sample Rate" to 60 reports/second. By default it set at 100 r/s, also I recommend to increase the input buffer to 120.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50