Choowkee Jun 11 @ 11:46am
[Confirmed] Fix to sound degradation/performance issues
For anyone still having issue with the sound slowly becoming crap after you launch the game, here is something that fixed the issue for me:

Step by step guide:

1. Exit Steam.
2. Go to your steam folder (default: C:\Program Files (x86)\Steam\).
3. Right click Steam.exe and go to Properties.
4. Go to the Compatibility tab.
6. Tick the "Run this program as an administrator" box below.
8. Make sure Compatibility mode is disabled ("Run this program in compatibility mode for:" box must be unticked).
7. Click "Apply" or "OK".
8. Launch steam and SSF4AE, sound should be fixed.




-----------------------------------------------------------------------------------------------------



Old Guide: (only in case the step by step guide above does not work for you)


1. Exit Steam.
2. Go to your steam folder (default: C:\Program Files (x86)\Steam\).
3. Right click Steam.exe and go to Properties.
4. Go to the Compatibility tab.
5. Tick the "Compatibility mode" box and select Windows 7 from the list.
6. Tick the "Run this program as an administrator" box below.
7. Click "Apply" or "OK".
8. Launch Steam and SSF4AE (you can try navigating the menu or launching training mode).
9. Exit SSF4AE and Steam.
10. Navigate back to the steam folder and once again go to Steam.exe properties.
11. In the Compatibility tab untick the "Compatibility mode" box (leave the admin box selected).
12. Run Steam and SSF4AE again.
Last edited by Choowkee; Jun 13 @ 2:23am
Showing 1-15 of 70 comments
< >
Sleep Jun 11 @ 12:21pm 
we need to bump this up cos it does seem to work.
I had the compatibility set to win 7 , then I turned it of and trned run as admin on and it's fixed for me.
win 7 64 bit
i5-2500
Hd radeon 7770
Last edited by Sleep; Jun 11 @ 7:10pm
(Kpazz) Smokey Mcpot Jun 11 @ 3:33pm 
I didn't think this would work as I've tried switching compatibility and running admin and all other kinds of stuff but i followed this method and it's definitely fixed it. Run Steam in Windows 7 compatibility and loaded the game. Problem was still there. Closed steam and turned OFF compatibility mode and clicked to run as Admin. Loaded steam and run the game and it's been working since. Thanks very much for this info definitely need to tell more.
ChaseC95 Jun 11 @ 3:34pm 
Can anybody give a quick tutorial on how exactly to do that? sorry im kind of a noob with computers
superdude097 Jun 11 @ 3:39pm 
Bumping because this worked for me (with an additional step or two).

The box for Compatibility Mode was checked, but greyed-out so I could not uncheck it. If this is the case, click the button "Change settings for all users" and try unchecking it from there. If you're still having trouble, use regedit to backup your registry and then remove the key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers\C:\Program Files\Steam\Steam.exe"

System Specs
1) CPU name and model: AMD Phenom II x4 965
2) Graphics card/chip model: 2048MB ATI AMD Radeon HD 7800 Series (ATI AIB)
3) Video driver version number: 13.251.0.0
4) System memory size: 8.00GB Dual-Channel DDR3 @ 669MHz (9-9-9-24)
5) OS version: Windows 7 Home 64-bit SP1
6) OS language: American English
7) Motherboard: ASUSTeK Computer INC. M5A78L-M LX PLUS (AM3R2)

I'll link this thread in the stickied thread so more people see it.
superdude097 Jun 11 @ 3:46pm 
Originally posted by SKT1 Kiwi:
Can anybody give a quick tutorial on how exactly to do that? sorry im kind of a noob with computers

  1. Go to: C:\Program Files (x86)\Steam
  2. Find and right-click "steam.exe"
  3. Select "Properties"
  4. Go to the "Compatibility" tab
  5. Uncheck "Run this program in compatibility mode for:"
  6. If it is greyed out: click the button near the bottom of the window that says "Change settings for all users", uncheck it there and click "OK".
  7. Check "Run this program as an administrator"
  8. Click "OK"
Last edited by superdude097; Jun 11 @ 3:46pm
misled_youth11683 Jun 11 @ 4:24pm 
This fixed the audio problems and even improved my frame rate. Thank you!
seigejet Jun 11 @ 5:26pm 
Fixed the problem for me as well.
Hey guys Jun 11 @ 5:50pm 
Fixed the sound problem but my frame rate still stutters when it was always stable on GFWL
imthewalrus610 Jun 11 @ 7:27pm 
Also fixed my sound problem. Thanks for the tip!
Maverick Hunter J. Jun 11 @ 10:39pm 
Thank you very much for posting this Choowkee. As everyone has stated, your time and work to come up with this solution is very much appreciated. Now I can turn the music and sound effects back on, and go back to playing one of my many favorite fighting games.
poke shark Jun 12 @ 2:50am 
this needs to be sticky
PsychedelicPet Jun 12 @ 3:01am 
Man that's so weird! Worked for me as well
Kanaya Maryam Jun 12 @ 3:31am 
Its still got the massive performance leak
Fuhajins of Autumn Jun 12 @ 3:37am 
Originally posted by superdude097:
Bumping because this worked for me (with an additional step or two).

The box for Compatibility Mode was checked, but greyed-out so I could not uncheck it. If this is the case, click the button "Change settings for all users" and try unchecking it from there. If

This + renderingthing : OFF.

Finally i can play again.
Kanaya Maryam Jun 12 @ 4:08am 
Edit: Fixed must remember to allow admin priviliges, this was such a easy fix why isnt it patched yet.

Not only does it fix the soubnd issue but the performance issue 2, now instead of 100% cpu use it uses 56% and has no leak.

Well done you did crapcoms job before they could be botherd to do it
Last edited by Kanaya Maryam; Jun 12 @ 4:26am
Showing 1-15 of 70 comments
< >
Per page: 15 30 50
Date Posted: Jun 11 @ 11:46am
Posts: 70