Lost Planet: Extreme Condition - Colonies Edition
JackLaVaporiera Apr 10, 2013 @ 4:30am
(FIXED) - BIG DISAPPOINTMENT
I've tried the dx9 demo of "Extreme Conditions" and liked thus I decided to buy the "Colonies Edition" since this must be the same with some additional content, well, I'm still waiting for an answer from Steam support since I'm not able to get it work correctly.

As said to Steam support I'm a former MS SBS partner so I AM able to understand the error message that states something wrong about a DirectX DLL (d3d11.dll) but I'm not able to overcome the issue that manifest itself this way: on DX10 it will freeze after a variable amount of time, from 2 seconds to the time it takes to GFWL to attempt the connection which wouldn't happen since usually the game freezes before it happens, on DX9 the same but sometimes with added effect or artifacts that makes the game unplayable.

I've been able to play it only a couple of times but the lasst time I did it crashed (same dx3d11 error) while attempting to reload a checkpoint.

I have Steam, GFWL, DirectX and everything else set up in a perfect way, no UAC nor antivirus nor anything else messing with the game other than GFWL overlay that's needed to run the game otherwise I'd already got rid of it, nonetheless there are these random freezes from the very start that makes it impossible to play.

I've tried everything, single-multi-gpu, game config, compatibility with Vista (I'm on W7/64), disabled visual, running as admin (even if I'm usually runing a 24/7 admin account), tried DX SDK to debug, played with heavily tweaked/default VGA driver (latest) settings, none of the tries seemed to do anything in this regard

While I wait for an official answer I thought to ask if anyone else have experienced this kind of issue and in that case if he found a solution...

Thanks.


UPDATE: problem solved, interested ones please look at post 39 for details.
Last edited by JackLaVaporiera; Jul 30, 2013 @ 10:04pm
Showing 1-15 of 93 comments
< >
sinsim_GER May 5, 2013 @ 1:23am 
on DX10 it will freeze after a variable amount of time,
same problem here!
No patch found for this jet. Have give administrator rights to the exe files have not solved this. My systemspecs:
Win 7 64 quadcore 3ghz 8gb Ram Geforce Gtx 460 768mb
JackLaVaporiera May 5, 2013 @ 4:09am 
I have abandoned it for a while, your post reminds me I still have to solve this issue, my next move will be to contact capcom support since Steam one dropped me with a bunch of unfortunately useless suggestions (that for instance I had already tried) among which the only one with a pinch of hope is exactly the "ask capcom" one.

Planned for later or at last tomorrow.
テング May 8, 2013 @ 9:13pm 
Yeah I get it too on DX11, so I just play on DX9 and there's no crashes. Not the best fix, but it'll let you play the game.
JackLaVaporiera May 8, 2013 @ 9:29pm 
Originally posted by テング:
Yeah I get it too on DX11, so I just play on DX9 and there's no crashes. Not the best fix, but it'll let you play the game.

Well. on dx9 the game doesn't freeze but sometimes it gives off with werid artifacts that makes impossible to keep playing, the weird thing is that sometimes it works in dx10 and when it works it works, but usually crashes only when I die and the game reloads the last checkpoint, always on that f---ed d3dx11.dll, pretty sure there is a mess with both Steam and Games For Windows (Dies)Live APIs....while Steam overlay can be disabled GFWL one doesn't, I can bet a beer it's HIM...
...however I delayed any action since I have a lot of job to do lately, not enough time to loose myself on it unfortunately...
Limachi May 22, 2013 @ 1:00pm 
I just unistalled it as I can no longer take the game crashing in dx10 and having 15-25 fps in dx9. Only if there were mid mission save points I would be able to deal with it but I am always beginning the mission all over after a crash.
Last edited by Limachi; May 22, 2013 @ 1:01pm
テング May 23, 2013 @ 2:14am 
If you are getting 15 fps on DX9....it might not be the game.
JackLaVaporiera May 23, 2013 @ 3:44am 
I'm currently waiting for an answer from Capcom, I'll udate as soon as I get something from them.
Gioppa May 26, 2013 @ 12:42pm 
my copy of LP Colonies don't start in dx9 and in dx 10...you are lucky if it start...i contact the support but...nothing
JackLaVaporiera May 26, 2013 @ 1:08pm 
Originally posted by Gioppa:
my copy of LP Colonies don't start in dx9 and in dx 10...you are lucky if it start...i contact the support but...nothing

Lucky is a big word, let say it started maybe 4 times in dx10 of which a couple of times I have been able to play a couple of missions, nonetheless when the game loaded again (reloaded a checkpoint) had the very same freeze, and in dx9 it starts, I can play few minutes then suddenly it goes corrupt somehow till becomes unplayable after a little while. Both the demo instead, dx9 and dx10, without GFWL, works perfectly.

I found the reason behind it most likely being related to GFWL but I simply do not accept Steam dropping me to Capcom and the latter dropping me to Microsft, the game is unplayable for reasons tied to the DRM system ? I don't care who, someone needs to fix it and I'm ready to do all the needed noise. And I do not have to go begging around for support, the "game" is a software and needs to be fully usable, not partially and the "ask Godfather" or "have faith in Him" way.
Last edited by JackLaVaporiera; May 26, 2013 @ 1:10pm
JackLaVaporiera May 26, 2013 @ 1:25pm 
Originally posted by Limachi:
I just unistalled it as I can no longer take the game crashing in dx10 and having 15-25 fps in dx9. Only if there were mid mission save points I would be able to deal with it but I am always beginning the mission all over after a crash.

Yes, I know it, it's very frustrating, just too much even for the most patient players.

But I'll get this to be fixed somehow.

I'm currently waiting for Lost Planet 3, Remember Me and other Capcom stuff, I can always cancel all preorders and spread the word on the net of how much they do care about customers, a sequel is coming out and you don't allow players to begin with the first episode ? I'll make them could ..."remember me" ...
JackLaVaporiera May 26, 2013 @ 1:32pm 
...I can grant you...
Typhoid Mary May 27, 2013 @ 9:28pm 
My game runs fine on W7/64. C2Q Q9500@3.4GHz, Radeon 7970, Corsair 2x2Gb 1066MHz
JackLaVaporiera May 27, 2013 @ 10:41pm 
Originally posted by ugly_smollett:
My game runs fine on W7/64. C2Q Q9500@3.4GHz, Radeon 7970, Corsair 2x2Gb 1066MHz

Well, mine doesn't on i7-3770k, 16GB-2400C10, GTX690 (tried everything still the overlay(?) error appears).
Zarrx Jun 1, 2013 @ 8:39am 
I had a xlive.dll error and i had to download games for windows live and your .dll error sounds like something to do with out dated direct x or you don't have it installed but I doubt that's the case.
-no problems here on dx10
Last edited by Zarrx; Jun 1, 2013 @ 8:40am
JackLaVaporiera Jun 1, 2013 @ 9:07am 
Originally posted by {EXD} Zarrx:
I had a xlive.dll error and i had to download games for windows live and your .dll error sounds like something to do with out dated direct x or you don't have it installed but I doubt that's the case.
-no problems here on dx10

I don't want to jinx you or anything but it seems you're speaking too soon, actually at 0.6 hour like you I was still thinking that nothing like what happened could even occur, the xlive.dll error to which you are referring to is the same happening on my system and subsequently the game freezes 99% of the times, maybe you have been just lucky at the first attempt and got it to work at the first attempt but I'm nearly sure it will crash at the first istance you will try to reload a checkpoint, if it behaves like on my system, and, however, my directx are fine and I'm not the only one experiencing this thing, speaking of the Colonies edition, I don't know about the old version though. I'm a pretty advanced user, believe me, I'm not having "visions".
Showing 1-15 of 93 comments
< >
Per page: 15 30 50