Lost Planet: Extreme Condition - Colonies Edition

Lost Planet: Extreme Condition - Colonies Edition

DarklordKyo Oct 13, 2013 @ 9:57pm
audio desync
During the cutscene before mission 1, there was quite a bit of desync between the audio & video, is there something I can do to fix this?
< >
Showing 1-4 of 4 comments
OldSoul Oct 14, 2013 @ 6:55pm 
Yeah I have the same issue, very annoying at times.
SirSagramore Jan 20, 2014 @ 4:04pm 
If you are using Windows 7, there is a Windows update that messes up how DirectX plays this game. Look for and uninstall Update KB2670838 and everything should synch up wonderfully the next time you play.
DarklordKyo Jan 20, 2014 @ 4:38pm 
I did that, the audio desynced despite it.
ThreeSon May 21 @ 1:18am 
You can fix this by limiting the FPS to 60. Go into the PC Settings menu and set the display frequency to 60 Hz. Also you may need to make an adjustment to the Lost Planet profile in your GPU control panel:

For Nvidia users, make sure "Preferred Refresh Rate" is at "Application Controlled" not "Highest Available."

I'm not sure what the equivalent setting is for AMD users, but it will be something similar to that.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50