GRID 2 > General Discussion > Topic Details
*FPCG| 385roller Jul 25, 2013 @ 6:45pm
Massive lag or?
Hello all. I am new to the online side of Grid 2, but not offline. I started playing online yesterday and noticed i have an issue which i believe is lag. When i am playing, the game will freeze for a moment and next thing i know i am wrecked. I have a decent pc, 15 4670k cpu, gtx 660 ti sc gpu and 2 terrabyte hdd. I also have cable internet which i get 28 mpbs down and 6.5 up. I have graphics turned to ultra low(doesn't seem to help). What do you think is going on here? I really think i would enjoy the online side, but it's not playable like this! :( Any help greatly appreciated!
Showing 1-4 of 4 comments
< >
Tig Ol Bitties (Banned) Jul 25, 2013 @ 10:20pm 
Lag or cheaters. In either event, bad programming from CodeWreckers.
NioNai *Deployed* Jul 25, 2013 @ 11:06pm 
Now is the time that hackers and cheaters are gaining access to all games.

PC's are cheap, and hackers/cheaters think its funny to ruin peoples experiences.

Ares Aug 8, 2013 @ 1:39pm 
It's just bad netcode... never met a cheater...
Just get this f....ing lags away... this stupid game is unplayable online..
It stutters for a while.. the cars nearby get transparent... timelap is impossible to win that way...
*FPCG| 385roller Aug 8, 2013 @ 2:29pm 
Try this! Worked great for me! Problem fixed!
http://www.youtube.com/watch?v=oU8Wh9LM9YQ
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Jul 25, 2013 @ 6:45pm
Posts: 4