Silverfall > General Discussions > Topic Details
Andrius227 Sep 17, 2013 @ 5:16am
Fps drops and stuttering.
So yeah i get low fps (as low as 30) while zoomed in. Also the game is stuttering most of the time. Is there a way to fix it ?

Specs: Win7, i7-2600 quad core @3.4ghz, 8gb ram, gtx 680.
Showing 1-5 of 5 comments
< >
lPaladinl Sep 17, 2013 @ 7:23pm 
You need to check all of your drivers would be my first guess. That or something odd with your motherboard.

I'm just running an i5 @2.53 ghz with integrated graphics and doing fine.
Andrius227 Sep 18, 2013 @ 12:24am 
Originally posted by lPaladinl:
You need to check all of your drivers would be my first guess. That or something odd with your motherboard.

I'm just running an i5 @2.53 ghz with integrated graphics and doing fine.

Drivers are up to date. I can play most other games fine, so it must be poor game optimisation or something. There must be a fix or a trick to make it run smooth.
Robot Kitty Sep 21, 2013 @ 7:20am 
I am having the same problem with stuttering, gtx 570 card..run almost every other game(except for older games sometimes, for some reason) fine and drivers are up to date.

I also installed legacy drivers.
Andrius227 Sep 21, 2013 @ 11:28am 
Originally posted by Bob Sackamano:
I am having the same problem with stuttering, gtx 570 card..run almost every other game(except for older games sometimes, for some reason) fine and drivers are up to date.

I also installed legacy drivers.

Strange thing is that i could play this game fine on my ~6 yr old pc.. Not maxed out, but without any stuttering...
lPaladinl Sep 22, 2013 @ 2:08am 
Have you guys tried adjusting your post-effects settings via the nVidia settings driver? Try turning off Anti-aliasing and Anisotrophic filtering and such. Try turning the settings to be lower.

Or, if your settings are already set to be low, try turning them higher.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50