Team Fortress 2
Team Fortress 2 > Virtual Reality > Подробиці теми
Oculus Rift - Crash on Mac
Anyone else running into this crashing problem when trying to run "-vr" mode?
< >
Показані коментарі 19 із 9
yes, i cannot get it to run :(
Same issue here, it crashes and says

hl2_osx quit unexpectedly

This is the output in the log https://gist.github.com/johnrees/3127e11e4bbc1bf86e35
New release works! Horray! Unfortunately TF2 on Mac doesn't, but... pulling the oculus_tracker.dylib over from HalfLife 2 to TF2 made it work. Just couldn't calibrate, that was messed up.
I had the same problem. I tried your solution, but I did not find "oculus_tracker.dylib"

Instead I copied "headtrack_oculus.dylib" from /Users/USERNAME/Library/Application Support/Steam/SteamApps/common/Half-Life 2/bin to the Team Fortress 2/bin folder.

Now it works, thanks!
Автор останньої редакції: receter; 28 тра 2013 о 1:13
Is there any way that you could share headtrack_oculus.dylib somehow please? I haven't got HL2 on Steam, although now it has VR support that will probably change soon! Thanks
Huge thanks for that file receter. Whilst it now opens without crashing with the -vr command in place, unfortunately it isn't split screen etc. I've also got 'prerelease - Latest available build' checked for TF2 but haven't had any joy.
That's great to have it resolved, even with some fiddling needed! Steam Mac support has pushed me over the fence: I'm getting a Rift one of these days. TF2, Half Life 2, and Unity alone will keep me busy for ages...
< >
Показані коментарі 19 із 9
На сторінку: 15 30 50

Team Fortress 2 > Virtual Reality > Подробиці теми