Team Fortress 2
Team Fortress 2 > Virtual Reality > Λεπτομέρειες θέματος
plasmoid 21 Μαϊ, 2013 στις 11:43μμ
Oculus Rift - Crash on Mac
Anyone else running into this crashing problem when trying to run "-vr" mode?
< >
Εμφάνιση 1-9 από 9 σχόλια
ddrei 27 Μαϊ, 2013 στις 3:37πμ 
yes, i cannot get it to run :(
bitsushi 27 Μαϊ, 2013 στις 8:44πμ 
Same issue here, it crashes and says

hl2_osx quit unexpectedly

This is the output in the log
plasmoid 27 Μαϊ, 2013 στις 8:46μμ 
New release works! Horray! Unfortunately TF2 on Mac doesn't, but... pulling the oculus_tracker.dylib over from HalfLife 2 to TF2 made it work. Just couldn't calibrate, that was messed up.
receter 28 Μαϊ, 2013 στις 1:12πμ 
I had the same problem. I tried your solution, but I did not find "oculus_tracker.dylib"

Instead I copied "headtrack_oculus.dylib" from /Users/USERNAME/Library/Application Support/Steam/SteamApps/common/Half-Life 2/bin to the Team Fortress 2/bin folder.

Now it works, thanks!
Τελευταία επεξεργασία από receter; 28 Μαϊ, 2013 στις 1:13πμ
bitsushi 28 Μαϊ, 2013 στις 2:27πμ 
Is there any way that you could share headtrack_oculus.dylib somehow please? I haven't got HL2 on Steam, although now it has VR support that will probably change soon! Thanks
receter 28 Μαϊ, 2013 στις 7:11πμ 
Here is the file:
bitsushi 30 Μαϊ, 2013 στις 11:43πμ 
Huge thanks for that file receter. Whilst it now opens without crashing with the -vr command in place, unfortunately it isn't split screen etc. I've also got 'prerelease - Latest available build' checked for TF2 but haven't had any joy.
Zareed JESUS 19 Ιουν, 2013 στις 9:57πμ 
Get a pc
nagromme 6 Ιουλ, 2013 στις 7:39μμ 
That's great to have it resolved, even with some fiddling needed! Steam Mac support has pushed me over the fence: I'm getting a Rift one of these days. TF2, Half Life 2, and Unity alone will keep me busy for ages...
< >
Εμφάνιση 1-9 από 9 σχόλια
Ανά σελίδα: 15 30 50

Team Fortress 2 > Virtual Reality > Λεπτομέρειες θέματος
Ημ/νία ανάρτησης: 21 Μαϊ, 2013 στις 11:43μμ
Αναρτήσεις: 9