Team Fortress 2 > Virtual Reality > Themendetails
plasmoid 21. Mai 2013 um 23:43 Uhr
Oculus Rift - Crash on Mac
Anyone else running into this crashing problem when trying to run "-vr" mode?
Beiträge 1 - 9 von 9
< >
ddrei 27. Mai 2013 um 3:37 Uhr 
yes, i cannot get it to run :(
bitsushi 27. Mai 2013 um 8:44 Uhr 
Same issue here, it crashes and says

hl2_osx quit unexpectedly

This is the output in the log https://gist.github.com/johnrees/3127e11e4bbc1bf86e35
plasmoid 27. Mai 2013 um 20:46 Uhr 
New release works! Horray! Unfortunately TF2 on Mac doesn't, but... pulling the oculus_tracker.dylib over from HalfLife 2 to TF2 made it work. Just couldn't calibrate, that was messed up.
receter 28. Mai 2013 um 1:12 Uhr 
I had the same problem. I tried your solution, but I did not find "oculus_tracker.dylib"

Instead I copied "headtrack_oculus.dylib" from /Users/USERNAME/Library/Application Support/Steam/SteamApps/common/Half-Life 2/bin to the Team Fortress 2/bin folder.

Now it works, thanks!
Zuletzt bearbeitet von receter; 28. Mai 2013 um 1:13 Uhr
bitsushi 28. Mai 2013 um 2:27 Uhr 
Is there any way that you could share headtrack_oculus.dylib somehow please? I haven't got HL2 on Steam, although now it has VR support that will probably change soon! Thanks
bitsushi 30. Mai 2013 um 11:43 Uhr 
Huge thanks for that file receter. Whilst it now opens without crashing with the -vr command in place, unfortunately it isn't split screen etc. I've also got 'prerelease - Latest available build' checked for TF2 but haven't had any joy.
✪Zareed 19. Juni 2013 um 9:57 Uhr 
Get a pc
nagromme 6. Juli 2013 um 19:39 Uhr 
That's great to have it resolved, even with some fiddling needed! Steam Mac support has pushed me over the fence: I'm getting a Rift one of these days. TF2, Half Life 2, and Unity alone will keep me busy for ages...
Beiträge 1 - 9 von 9
< >
Pro Seite: 15 30 50
Geschrieben am: 21. Mai 2013 um 23:43 Uhr
Beiträge: 9