Team Fortress 2
Team Fortress 2 > Virtual Reality > Détails du sujet
plasmoid 21 mai 2013 à 23h43
Oculus Rift - Crash on Mac
Anyone else running into this crashing problem when trying to run "-vr" mode?
< >
Affichage des commentaires 1 à 9 sur 9
ddrei 27 mai 2013 à 3h37 
yes, i cannot get it to run :(
bitsushi 27 mai 2013 à 8h44 
Same issue here, it crashes and says

hl2_osx quit unexpectedly

This is the output in the log
plasmoid 27 mai 2013 à 20h46 
New release works! Horray! Unfortunately TF2 on Mac doesn't, but... pulling the oculus_tracker.dylib over from HalfLife 2 to TF2 made it work. Just couldn't calibrate, that was messed up.
receter 28 mai 2013 à 1h12 
I had the same problem. I tried your solution, but I did not find "oculus_tracker.dylib"

Instead I copied "headtrack_oculus.dylib" from /Users/USERNAME/Library/Application Support/Steam/SteamApps/common/Half-Life 2/bin to the Team Fortress 2/bin folder.

Now it works, thanks!
Dernière modification de receter; 28 mai 2013 à 1h13
bitsushi 28 mai 2013 à 2h27 
Is there any way that you could share headtrack_oculus.dylib somehow please? I haven't got HL2 on Steam, although now it has VR support that will probably change soon! Thanks
bitsushi 30 mai 2013 à 11h43 
Huge thanks for that file receter. Whilst it now opens without crashing with the -vr command in place, unfortunately it isn't split screen etc. I've also got 'prerelease - Latest available build' checked for TF2 but haven't had any joy.
Zareed-No Kappa 19 juin 2013 à 9h57 
Get a pc
nagromme 6 juil 2013 à 19h39 
That's great to have it resolved, even with some fiddling needed! Steam Mac support has pushed me over the fence: I'm getting a Rift one of these days. TF2, Half Life 2, and Unity alone will keep me busy for ages...
< >
Affichage des commentaires 1 à 9 sur 9
Par page : 15 30 50

Team Fortress 2 > Virtual Reality > Détails du sujet