Team Fortress 2
Team Fortress 2 > Virtual Reality > Topic Details
plasmoid May 21, 2013 @ 11:43pm
Oculus Rift - Crash on Mac
Anyone else running into this crashing problem when trying to run "-vr" mode?
< >
Showing 1-9 of 9 comments
ddrei May 27, 2013 @ 3:37am 
yes, i cannot get it to run :(
bitsushi May 27, 2013 @ 8:44am 
Same issue here, it crashes and says

hl2_osx quit unexpectedly

This is the output in the log
plasmoid May 27, 2013 @ 8:46pm 
New release works! Horray! Unfortunately TF2 on Mac doesn't, but... pulling the oculus_tracker.dylib over from HalfLife 2 to TF2 made it work. Just couldn't calibrate, that was messed up.
receter May 28, 2013 @ 1:12am 
I had the same problem. I tried your solution, but I did not find "oculus_tracker.dylib"

Instead I copied "headtrack_oculus.dylib" from /Users/USERNAME/Library/Application Support/Steam/SteamApps/common/Half-Life 2/bin to the Team Fortress 2/bin folder.

Now it works, thanks!
Last edited by receter; May 28, 2013 @ 1:13am
bitsushi May 28, 2013 @ 2:27am 
Is there any way that you could share headtrack_oculus.dylib somehow please? I haven't got HL2 on Steam, although now it has VR support that will probably change soon! Thanks
bitsushi May 30, 2013 @ 11:43am 
Huge thanks for that file receter. Whilst it now opens without crashing with the -vr command in place, unfortunately it isn't split screen etc. I've also got 'prerelease - Latest available build' checked for TF2 but haven't had any joy.
ZareedFinnagan Jun 19, 2013 @ 9:57am 
Get a pc
nagromme Jul 6, 2013 @ 7:39pm 
That's great to have it resolved, even with some fiddling needed! Steam Mac support has pushed me over the fence: I'm getting a Rift one of these days. TF2, Half Life 2, and Unity alone will keep me busy for ages...
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Team Fortress 2 > Virtual Reality > Topic Details
Date Posted: May 21, 2013 @ 11:43pm
Posts: 9