Team Fortress 2 > Virtual Reality > 主题详情
ninjabot 2013年4月19日下午6:13
Game crash in VR mode
When I launch TF2 with the -vr option, the game crashes right after the opening cinematic. I never get a glimpse of the loading screen for the main menu. If I remove the -vr startup switch, then the game launches properly and runs without any problems. I haven't had problems running any of the OR demo apps, so I know that the device is working alright. Anybody have an idea of what I can try?
正在显示第 1 - 15 条,共 19 条留言
< >
LockeDown 2013年4月20日上午9:51 
I have not had this problem but is the Rift your primary display or mirroring your primary display? Or are you using a splitter?
ninjabot 2013年4月20日下午12:45 
It's mirroring my primary display.
LockeDown 2013年4月24日下午8:37 
Try this.. I had the same problem when trying on a new machine. Make sure to load TF2 without -vr (normal) and load up a practice session. After playing the practice session - quit and reload with -vr and it should work.

I think there are issues with it loading if you have not played normal mode on the machine or recently.
ninjabot 2013年4月25日下午12:15 
Well I'll never know what the actual root cause was, but it's working fine for me now. I was having a lot of other small issues with this box so I ended up reloading Windows out of frustration. I appreciate you taking the time to help. What you suggested may very well have worked for me, since it had been a couple years since I last played any TF2.
LockeDown 2013年4月25日下午9:14 
No problem. Glad your issue was resolved and maybe this thread can help others that have a similar issue.
Hall1day 2013年4月27日下午12:36 
I have the same problem as ninjabot. Unfortunately playing a mission in non-vr mode didn't help in my case :-(. I also tried it with and without Hydra but it always crashes after the intro video. any other suggestions?
ninjabot 2013年4月27日下午5:48 
Are you running Windows? If so, what version? One obvious troubleshooting step that didn't occur to me was to check the application event log.
Slortz 2013年4月29日上午4:19 
Same issue as Hall1day :( windows 7, ati 6950
Slortz 2013年4月29日上午5:22 
Seems to be fixed now, I had the resolution set to 720, not 800, all working now
SwogDog 2013年5月3日下午8:04 
引用自 Slortz
Seems to be fixed now, I had the resolution set to 720, not 800, all working now

Oh man, thank you! This was my problem, too. I assumed vr mode would set the correct resolution when the game launched. Apparently it does not.
Chimera91 2013年5月24日上午3:33 
I still got the problem where you only see the splash screen and the initial load screen but blacking out the main menu...ive tried to change the settings but the game seems to be ignoring the changes and staying in its default broken state. I'm running out of ideas.
Luke 2013年5月27日上午5:16 
Having the same issue tried all of above.
Tried setting the to the Scaled 720p.
I'm on Macbook Pro Retina which I think might be causing the issue.... Any one have suggestions?
Enki666 2013年6月1日下午12:08 
I am having problems too. I tried changing the resolution within the game but did not fix the problem. I switched prerelease on but that did not fix the problem. I tried first starting a practice match in regular mode then go back to vr mode, but did not fix the problem. I adjusted my computer's main resolution, did not fix the problem. Running out of ideas here. I've exhausted all the suggestions I could find within this forum. The Oculus forum is not helpful.
Enki666 2013年6月1日下午11:24 
On top of my last posting, I downloaded the TF2 Beta. I enabled vr mode and this time the screen did not go black. The game menu came up as normal. But I was not able to get the vr_calibration to work.
Enki666 2013年6月6日上午10:55 
Still not working.
正在显示第 1 - 15 条,共 19 条留言
< >
每页显示数: 15 30 50