Team Fortress 2 > Virtual Reality > Dettagli della discussione
jake 9 apr 2013, ore 22:33
Oculus not full screen or resolution
I'm following the wiki and using -vr in the set launch options, but the game opens at 1220x and only fills the top left corner of my 1920x1080 monitor and oculus.

I've tried using -fullscreen in the launch options but -vr overwrites this. I've also tried adjusting the settings in the game menu but the game view always stays the same size... ie. doesn't work with oculus. I'm dying to try tf2 out on the oculus. any help?
Visualizzazione di 1-7 commenti su 7
< >
DosBoss 10 apr 2013, ore 1:08 
If I read the SDK manual right, you'll need to set the resolution to 1280 x 800, as that's the resolution of the rift's screen, (try setting it both in windows and tf2)
jake 10 apr 2013, ore 9:09 
perfect thanks. for some reason i though the rift was 1920x1080. changing the resolution solved the problem
DosBoss 10 apr 2013, ore 11:19 
no problem :), have fun!
glass 24 apr 2013, ore 11:14 
it would be nice if TF2 with -vr option went fullscreen properly, to avoid having to set the desktop to 1280x800 when playing it. there's no real reason why not.
WormSlayer 10 lug 2013, ore 12:54 
Yes please fix this, having to change your desktop resolution before and after you play is rather annoying.
kdawg 29 ago 2013, ore 1:22 
-vr will work properly as long as u got the screen setup on duplicate and not extend
¯\(°_0)/¯ 10 set 2013, ore 17:13 
Messaggio originale di Kdawg (oculus mode):
-vr will work properly as long as u got the screen setup on duplicate and not extend

VR mode works fine on extend. There is very little reason to duplicate your Rift while playing TF2. No matter which adapter your Rift is on, setting -vr will cause the game to to display directly to your Rift and no other monitor. Duplicate can be handy for showing other people the game, but nothing else.

This applies to all the other games that Valve has added VR support to as well.
Visualizzazione di 1-7 commenti su 7
< >
Per pagina: 15 30 50