Team Fortress 2 > Virtual Reality > Topic Details
JFK Jan 28 @ 11:49am
[ISSUE]Stuck in windowed mode after trying out the Oculus Rift with TF2
I tried out the VR-mode a couple of days ago and it all worked fine. Now when I'm trying to play normally I'm stuck in windowed mode and changing to full-screen in settings won't do anything (the next time I open the options it's back at windowed).

The Virtual Reality mode also seems to be stuck in enabled since I don't have an compatible device plugged in (I don't have access to the Oculus anymore), but the game's acting like it's disabled except for it being windowed and that I got the "Activate Virtual Reality Mode" button in the main menu.

I don't have any launch options atm and putting in things like -fullscreen doesn't do anything.
Would appreciate help!
Showing 1-6 of 6 comments
< >
Stanith Jan 29 @ 2:53pm 
I have this exact same problem, I'm stuck in "Virtual Reality Enabled" mode with no way of disabling it.

However, running the game with -noborder pretty much solves the full screen problem :) Even though it's not strictly full screen mode, it runs in border-less windowed mode which when set to the native resolution has more or less identical behaviour. Hope this helps until there's a proper fix!
JFK Jan 29 @ 4:34pm 
Yeah, that's what I'm currently using. It's a temporary fix, but fullscreen works better :/
Eric2399 Feb 13 @ 7:25pm 
I had this same problem, i just kept playing around and if you change the resolution it should go fullscreen on one
Vertigo Apr 27 @ 6:07pm 
I also have this, its quite irritating. Would be nice if Valve could comment on how to fix this.
•GG• Ace2020boyd May 3 @ 7:10pm 
I'm having this problem right now annoying
RadioaktivSkwerl May 19 @ 3:24pm 
I have found a solution for anyone wondering how to fix this. I've been struggling with this for quite a while and figured out a solution. (I found this discussion via Google so if I'm necro'ing an old discussion I apologize, but I really wanted to get this solution out there for people to find 'cause it drove me nuts and I'm sure I'm not the only one.)

Right-click TF2 in your library and hit "Properties"
Set Launch Options and put the text: -autoconfig
Save those settings and launch TF2. If all goes well it should reset your configurations and force disable the VR mode in video settings.

After this you are free to close TF2, delete the -autoconfig text and relaunch it if you don't use all of the default video settings and with that text removed you're free to re-customize your video settings back to what you had before and those should stick when saved.

Hope this helps you guys. C:
Last edited by RadioaktivSkwerl; May 19 @ 3:29pm
Showing 1-6 of 6 comments
< >
Per page: 15 30 50