Apollo Sep 29, 2013 @ 2:05pm
Steam Guard
how can I turn it on? I want to trade with people in servers when I`m playing
Showing 1-7 of 7 comments
< >
efflandt Sep 29, 2013 @ 2:09pm 
In Steam > Settings menu. Steam Guard has to be enabled for over 15 days before you can trade.
Apollo Sep 30, 2013 @ 10:20am 
Originally posted by efflandt:
In Steam > Settings menu. Steam Guard has to be enabled for over 15 days before you can trade.
Thanks dude!!!
P.S. 15 days!!! why
M.B. Rancor Marionette Sep 30, 2013 @ 10:43am 
For your protection. Be lucky it's only 15 days.
ObsidianCrafter Sep 30, 2013 @ 10:48am 
I wish that you didn't have to wait 15 days. It's ♥♥♥♥ing annoying..
Tarpet (Banned) Sep 30, 2013 @ 11:43am 
Originally posted by Boba Fett:
I wish that you didn't have to wait 15 days. It's ♥♥♥♥ing annoying..
Its for your own safety.
TheCanadianBrit Jan 24 @ 10:27am 
how do you enable it? i can see it on the account settings on the menu but theres no "enable steam guard" button or anything. HELP!
Faceless Male ⑨ (Banned) Jan 24 @ 10:29am 
Originally posted by Monkey_Sensei:
how do you enable it? i can see it on the account settings on the menu but theres no "enable steam guard" button or anything. HELP!
You ⑨.........
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Sep 29, 2013 @ 2:05pm
Posts: 7