FlameAss Jun 18, 2013 @ 1:36am
I have a problem and i need help. Please?
hi guys, have been playing tf2 for quite a while now and recently i encountered a nasty problem.

while playing, i will have a nasty problem of my graphics lagging badly and sounds as well. like if usually the voice will say:" mission begins in.....", it will sound instead like: "mission mission mission begins begins begins in in in.." like stuttering. the graphics will be like watching powerpoint slides. i hope u guys get the drift.

i have no idea what causes it to be this way and i cant enjoy my game like this =(
it's not the connection cos I have less than 100 ping on the servers i play.

my specs are as follows:
ASUS X42J series
Processor & Cache Memory: Intel® Core™ i7 Processor 720QM : 1.6 GHz with Turbo Boost up to 2.8 GHz (i dunno how to turbo boost btw)
Operating System Genuine Windows® 7 -64bit
Main Memory 4GB DDR3 1066 MHz SDRAM
Video Graphics & Memory ATI Mobility™ Radeon® HD 5470, 1G DDR3 VRAM

what other info is needed???


I really want to fix this problem asap. any help is deeply appreciated..

Thanks in advance.
Showing 1-11 of 11 comments
< >
Enigmantic Jun 18, 2013 @ 1:40am 
Do you have a wireless router? If so try unplugging it for about a minute and then plug it back in. I had the same problem as you and a simple reset of the router solved it for me.
FlameAss Jun 18, 2013 @ 2:06am 
Originally posted by Enigmantic:
Do you have a wireless router? If so try unplugging it for about a minute and then plug it back in. I had the same problem as you and a simple reset of the router solved it for me. :medicon:
i've tried that as well. i dun think it's my internet. cos the same thing happen when i try to play skyrim too. it doesnt require internet connection cos i BT it.
muckymucks Jun 18, 2013 @ 2:07am 
Have you tried verifying your cache? How about lowering the game's settings?
FlameAss Jun 18, 2013 @ 2:14am 
Originally posted by muckymucks:
Have you tried verifying your cache? How about lowering the game's settings?
yes i did those too... but it didnt help much... im worrying that i may have to reformat my whole laptop and backup can be such a hassle and im trying to avoid it
W+M1 Pyro Jun 18, 2013 @ 2:24am 
Your ram and gfx look relatively weak. Try lowest resolution with lowest setting.
Handsome Jack Here Jun 18, 2013 @ 2:33am 
Give Health for your PC .
FlameAss Jun 18, 2013 @ 2:39am 
Originally posted by W+M1 Pyro:
Your ram and gfx look relatively weak. Try lowest resolution with lowest setting.
i've switched to lowest setting, have not tryed lowest res yet.
QN: does have 2GB of space left in C drive affects anything?? i've tried to uninstalled all misc stuff from C drive and i think windows updates just ate up tons of space...
TrollMaserHD Jun 18, 2013 @ 2:46am 
asd
☆[๖ۣۜSeKc]-TΣMPERR»™ Jun 18, 2013 @ 2:57am 
ive also had this problem friend me and we can try and figure this out together
FlameAss Jun 18, 2013 @ 3:58am 
Originally posted by MAN EATER:
ive also had this problem friend me and we can try and figure this out together
yea sure, im reinstalling TF2 to see if that helps... i hope someone could give some pro advice(not that the rest above are not helpful, im hoping for some pro diagnostic or something since im not that tech savvy)
FlameAss Jun 18, 2013 @ 7:30am 
try to keep this discussion up there for help
-bump-
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Jun 18, 2013 @ 1:36am
Posts: 11