Ellander Feb 18, 2013 @ 5:49pm
TF2 won't launch - flashes black screen then I'm back at Steam
I have Ubuntu 12.10and an Asus HD 7770. I've tried all three AMD drivers in the Software Sources. Any tips on getting a video driver that works?
Showing 1-6 of 6 comments
< >
Orange Bitflip Feb 18, 2013 @ 6:24pm 
Step 1, Call AMD.
Step 2, Wait for 4 hours before somebody answers.
Step 3, Scream at them for being the incompetent fools they are.
Step 4, Mention Linux's OpenGL drivers.
icehat Feb 18, 2013 @ 6:45pm 
If you can, stick with the default community-maintained drivers, the drivers that AMD supplies are complete crap.
Last edited by icehat; Feb 18, 2013 @ 6:45pm
Ellander Feb 18, 2013 @ 9:41pm 
I got it running. I uninstalled my existing drivers and downloaded fresh drivers for catalyst.
Macan Feb 20, 2013 @ 4:23am 
Install the latest AMD Catalyst drivers

my configuration
Pentium G860
Radeon HD 5670
Linux MINT14 (Should be the same like UBUNTU 12.10 Q)

1. Remove (purging) existing drivers (write in to the terminal):
sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
(write your password if you are asked for)
(close terminal)
- you cannot install new drivers until you remove the old ones

2. Download the newest drivers from:
http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx
(not the beta). The latest drivers at present day are the AMD Catalyst™ 13.1 Proprietary Linux x86 Display Driver

3. Extract the downloaded zip archive file you have in your Downloads folder so you will get:
amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run
in your Download folder

4. Run Terminal and choose your Downloads folder (write: cd Downloads) then write
chmod +x amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run
sudo sh amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run

5. Restart your system:
sudo reboot

Without the drivers the TF2 are very slow.
After installation Radeon drivers from Software Manager the TF2 didn't launch - flashes black screen then I'm back at Steam (or desktop)
With Catalyst 13.1 the game goes smooth and fast.

I hope this will be helpful
There are also another ways to install the latest drivers.
Orange Bitflip Feb 20, 2013 @ 3:22pm 
Well, Jockey says the driver's active but not in use, and the X.org log says I'm using fglrx.
Yet I can't find a fglrx-uninstall.sh
Bah, I'll just go for it anyway. I've got Windows and ext4 just so I can go nuts.
Ellander Feb 23, 2013 @ 10:26am 
macan is mostly correct. that is what i did and although i got a ton of errors during the "uninstall" phase, the reinstall worked.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Feb 18, 2013 @ 5:49pm
Posts: 6