tsb47 Feb 18, 2013 @ 1:39am
[SOLVED] Won't work in Linux
I'm running Ubuntu 12.10 32 bit on a mid-end gaming rig (Radeon 6800, core i7, 6GB RAM). The game won't start. Trying to start gets me the Steam laoding dialogue for a moment. Then the Screen goes black for a second. Then I am straight back to desktop. Same problem with Counter Strike Source. I have tried both the regular propertiary drivers and the proposed-updated drivers and no joy. HELP

Edit: Horst's instructions worked. Uninstalled current ati drivers. Installed latest ati drivers using instructions here: http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29

Now work perfectly. THANKS HORST!
Last edited by tsb47; Feb 19, 2013 @ 1:11am
Showing 1-7 of 7 comments
< >
Cryptic Feb 18, 2013 @ 1:50am 
Same here, Worked briefly out of the box (albeit, badly)

Configured to use fglrx-updates and then boom (after first nuking my unity and having to reinstall it, thanks ctrl+alt+T !) (Terminal shortcut) no more launch.
OverlordTomala Feb 18, 2013 @ 2:24am 
I'm running this driver set without any issues.

Driver Version: 4.2.11978 Compatibility Profile Context
Cellendhyll de Cortavar Feb 18, 2013 @ 2:27am 
Hello
i'm running on ubuntu 12.04 32bits but Nvidia's graphic card (with experimental beta drivers) and it start well.
May be you will find a answer on ubuntu site

TakkaRakkaTakka Feb 18, 2013 @ 2:36am 
The driver version is not 4.2.xxxx, it's the OpenGL version. The driver version starts with 8 or 9, the newest version is 9.012 which corresponds to Catalyst 13.1.

I would say, update your drivers manually. Read this, mostly you just need to copy and paste the commands, but first uninstall the old drivers: http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide#Installing_Catalyst_Manually_.28from_AMD.2FATI.27s_site.29
tsb47 Feb 19, 2013 @ 1:11am 
Thanks Horst, that worked great. Now I can play no problems. You're awesome!
Cryptic Feb 19, 2013 @ 2:25am 
Yes, however.

I only got success from a small bunch of those commands. Several turned up failures (probably from previous attempts to fix it.)

HOWEVER, the steps that did work included uninstalling the previous drivers, so I just ran the downloaded Cat' drivers and away I went.

So thanks for steering me in the right path.
TakkaRakkaTakka Feb 19, 2013 @ 4:50am 
Yes, most of the commands will only work for the first time. Once you tried them you don't it for future installations anymore.

And for the future driver versions you can just go to the AMD's site, download the drivers from there, unzip, mark the .run file as executable and install them by a double click like in Windows.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Feb 18, 2013 @ 1:39am
Posts: 7