LibraryPimp Feb 17, 2013 @ 4:57am
help with linux
when i start the game is saying "the game is not avilable at the momment"
i Verify Integrity of Game Cache on the settings and it still isnt working
help?
Showing 1-10 of 10 comments
< >
Numel! Feb 17, 2013 @ 5:04am 
Linux TF2 might be getting a lot of pressure on the servers
LibraryPimp Feb 17, 2013 @ 5:06am 
my brother playing tf2 now on linux
Plastic Fork<Stiner> Feb 26, 2013 @ 6:27pm 
I am having the same issue. It will not become "available" for me. I have this problem once in a while on my WinXP (I know I need to upgrade) but a simple restart always fixed it. Anyone find a resolution?
Plastic Fork<Stiner> Feb 26, 2013 @ 6:33pm 
Incase it will help I am launching Steam out of the terminal and I receive this message after launching TF2: (Replace Home/personal info with ~)

CJoinGameDialog::OnSteamError() : launch game failed, with steam error:
SteamProcessCall(WaitForAppReadyToLaunch)(0xab1dc8,0xbfc53840,0xbfc53628) failed with error 1: Failed to create directory ~/.local/share/Steam/SteamApps/username/Team Fortress 2
Last edited by Plastic Fork<Stiner>; Feb 26, 2013 @ 6:50pm
Plastic Fork<Stiner> Feb 26, 2013 @ 6:53pm 
I am denied access (while using the terminal) to the User File inside of ~/.local/share/Steam/SteamApps

I Tried:

Sudo sudo mkdir username/Team Fortress 2

After creating the directory I tried to launch TF2 with the same error. This is some what frustrating.
<nLVc> da\/os Feb 26, 2013 @ 6:57pm 
As I replied in a different discussion, the issue is more than likely the size of your ubuntu partition.
The solution is, to increase the size of said partition. Google can help you with that one.

I had the same issues with Ubuntu because the partition I created was too small. I ditched ubuntu in favor of mint(which you do not have to do), but with a vastly larger partition. All works fine now.
Plastic Fork<Stiner> Feb 26, 2013 @ 7:07pm 
Davos,

Thanks for your reply. Could you supply me with the link to the other discussion and a some help determining which partition needs to be resized.

I have EXT4 (18.47gb/24.96gb), extended (3gb) and linux-swap (3gb). Currently I am using an older (30gb) HD for my Ubuntu install. Untill I can build my new machine.
LibraryPimp Feb 27, 2013 @ 4:10am 
thenk for the help
now i finaly got my sweet tux :)
and now just to wait for it to become tradeable and i will give it to my main account
thenk you dave and fork aprecited
PEACE
Plastic Fork<Stiner> Feb 27, 2013 @ 3:27pm 
Congrats bomboy! I'm a little jealous.

My resolution was to move my entire steam folder to an additional hard drive (80gb) using the terminal but was still not able to play due to an additional error.

After I moved the folder I started Steam. Ubuntu asked me if I moved the folder and I showed Ubuntu where I had moved it. I then tried to launch TF2 again with the same error but this time I noticed that the error stated access denied (access denied to ~/.local/share/Steam/SteamApps/username). I navigated to the file that TF2 was denied access to and found that I was also denied. After doing some searching I found a command to remove the restrictions on the folder (sudo chown username:username foldername (where username is your Ubuntu User name and foldername is your Steam User folder name)) and restarted Steam. This time when I launched TF2 I did not receive the above error... instead it was replaced with a new error stating that my graphics card was not supported.

Long story short. I resolved my first error but can not play TF2 on linux due to my graphics card not being supported. No Tux for me. :( I hope that this info helps some one else though.

If anyone needs any help drop me a comment and I will try to help you.
LibraryPimp Feb 28, 2013 @ 4:35am 
yea i know how you feel
i had alot of games (and have) that my graphic card cant handle them
well im sure you can find someone who got linux and can run tf2 for you
you can make a new account and wait till tux will be tradeable and you will get it :)
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Feb 17, 2013 @ 4:57am
Posts: 10