Team Fortress 2 > Algemene discussies > Details van topic
Kossak 16 feb 2013 om 3:50nm
TF2 linux performance problems
Hello,
On windows i have most of the graphics settings maxed out and tf2 plays very nicely. On linux i have about 3 fps... If someone could give me some tips how can i increase my playing experience on linux i would be grateful.

My new os: Ubuntu 12.10

My hardware:
ATI HD 6850
Intel Core 2 Duo E8400 3GHz
6 GB of RAM
Asus P5K PRO

In "Graphics" my ubuntu says "Driver Unknown, Experience Standard"
I googled some proprietary drivers and installed them: screenshot 1[i49.tinypic.com]
But when i try to activate one i get this error: screenshot 2[i49.tinypic.com]
And my jockey.log file looks like this[pastebin.com].

Any ideas how can i get better performance? Thanks in advance.
Laatst bewerkt door Kossak; 16 feb 2013 om 3:52nm
1-12 van 12 reacties weergegeven
< >
monkey2674 16 feb 2013 om 4:18nm 
I can never get jockey to work so I just install manual. Heres how to do it without terminal. Go to amd website and download the latest linux catalyst driver. Once complete go to your downloads folder and right mouse click on it and choose extract here. Now right mouse click on the extracted file and select properties. Then Permissions tab. Then check the box for allow executing file as a program. Now you can double click on the file and click run or run in terminal. Enjoy

To upgrade to a new catalyst just uninstall thru terminal with this command "sudo /usr/share/ati/amd-uninstall.sh" Then install the new one after its done.
monkey2674 16 feb 2013 om 4:27nm 
oh you may need to install unzip if you dont have it. Thru software center search unzip. Or Sudo apt-get install unzip in terminal.
Kossak 16 feb 2013 om 4:27nm 
I can't install it: error[i50.tinypic.com]
Mentioned file contains:
Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers. /lib/modules/3.5.0-23-generic/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
Kossak 17 feb 2013 om 3:42vm 
I would love to try this solution, but today my linux desktop (gnome?) just stopped working. I login into my account, and all i see is wallpaper and one icon on it (steam). The left/top taskbars don't load... :/
Laatst bewerkt door Kossak; 17 feb 2013 om 3:42vm
###O?qÿáÓ 17 feb 2013 om 4:21vm 
Try this![wiki.ubuntu.com]



Origineel geplaatst door Kossak:
I would love to try this solution, but today my linux desktop (gnome?) just stopped working. I login into my account, and all i see is wallpaper and one icon on it (steam). The left/top taskbars don't load... :/

Ubuntu is using unity. You can try to log out and log in again. That should fix your problem.
Kossak 17 feb 2013 om 4:36vm 
Origineel geplaatst door ###O?qÿáÓ:
Try this![wiki.ubuntu.com]



Origineel geplaatst door Kossak:
I would love to try this solution, but today my linux desktop (gnome?) just stopped working. I login into my account, and all i see is wallpaper and one icon on it (steam). The left/top taskbars don't load... :/

Ubuntu is using unity. You can try to log out and log in again. That should fix your problem.

I read that Ubuntu 12.10 doesn't use "unity" any more, and i don't see this unity desktop at login screen. I'll try tips on the page you linked.
monkey2674 17 feb 2013 om 5:36vm 
Ubuntu 12.10 dropped Unity 2D not Unity 3D. When you login Press Ctrl-Alt-T that will open terminal. Then Enter these 2 commands 1 at a time. "sudo apt-get purge fglrx lightdm" "sudo apt-get install lightdm ubuntu-desktop"
Kossak 17 feb 2013 om 7:28vm 
Origineel geplaatst door monkey2674:
Ubuntu 12.10 dropped Unity 2D not Unity 3D. When you login Press Ctrl-Alt-T that will open terminal. Then Enter these 2 commands 1 at a time. "sudo apt-get purge fglrx lightdm" "sudo apt-get install lightdm ubuntu-desktop"

This magic worked! Unity 3D works again :). Now what was my original problem.... hmmm such is life of new Linux user - so much problems that you forget what you wanted to fix initially :). Oh yes, TF2 performance and ATI driver.... let's cross my fingers i wont' break anything this time....
Kossak 17 feb 2013 om 8:23vm 
ok, after downloading "sudo apt-get install linux-headers-generic" i installed ATI graphic driver without any further problems, tried TF2 and... wow, the game works as smoothly as on windows! Thank you all for help :). Now If they ported Dota 2 to linux, i would have much less reasons for going back to windows :)

btw. they should link to this driver right on the main page for downloading steam for linux: http://store.steampowered.com/about/
blackout24 17 feb 2013 om 8:40vm 
To bad Ubuntu integrated the driver installation into the software center instead of using jockey like in previous version. In that case any new users would have a window pop up asking if he wants to install additional drivers for his/her graphics card. Select the latest. Install done.
In this case it would be more obvious for windows people that you don't have to download anything and install things from the Software Center.
monkey2674 17 feb 2013 om 8:55vm 
No problem. Glad to hear it worked for ya :)
1-12 van 12 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 16 feb 2013 om 3:50nm
Aantal berichten: 12