LonePiper Feb 15, 2013 @ 4:13am
Ubuntu with XBox360 controller help please
I've been playing tf2 on an Ubuntu variant for about a week. Just out of curiosity I downloaded xboxdrv, a linux driver for the xbox360 controller. It worked fairly well with tf2, and I actually preferred using the mouse with the controller instead of mouse and keyboard. But just today it's spontaneously stopped working, and the only culprit I can think of is the latest tf2 update that came in, because the controller still works with other games.

I've tried enabling and disabling tha gamepad in the options menu, I've tried "exec 360controller-linux" in the terminal, I've tried reinstalling xboxdrv and even removing it, in case it was clashing somehow with tf2's native driver, or whatever it has, and I've tried all of these steps with computer restarts. Nothing works! Tf2 makes no sign that the controller exists at all.

The only other thing I can add is that in the terminal, when I enter "exec 360controller-linux" and it's mapping the various joysticks and buttons, a red message usually comes up saying "ConVarRef hap_HasDevice doesn't point to an existing ConVar".
Any help or suggestions?
Showing 1-8 of 8 comments
< >
OverlordTomala Feb 15, 2013 @ 4:36am 
Report the bug to steam. It sounds like the latest update may have broken a convar.
LonePiper Feb 15, 2013 @ 4:38am 
Will do! Now, just to work out how exactly to do that...
*is a shiny green n00b*
LonePiper Feb 15, 2013 @ 5:00am 
Thanks, but I just worked out how to do it in-game. Would it be worth making another report through the website?
OverlordTomala Feb 15, 2013 @ 5:09am 
Ah if you did it in game there shouldn't be a problem then.
LonePiper Feb 15, 2013 @ 5:12am 
Just to be clear, I worked out how to report a bug in-game, not make the controller work!
(Not sure how you read my last statement)
OverlordTomala Feb 15, 2013 @ 5:13am 
Originally posted by LonePiper:
Just to be clear, I worked out how to report a bug in-game, not make the controller work!
(Not sure how you read my last statement)

No I understood. :) If you reported the bug to steam via game that's fine too, is what I'm saying.
UbuntuAddicted Feb 18, 2013 @ 9:43am 
i am having the same issue. when I run exec 360controller is appears to spit out some output but when I run exec 360controller-linux it spits out nothing and the controller doesn't work obviously. any help would be much appreciated. I am using xubuntu 12.04.1 so the xpad module is built into the kernel and i did load the module.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Feb 15, 2013 @ 4:13am
Posts: 8