Team Fortress 2 > Общи дискусии > Подробности за темата
Skirmisher 14 февруари 2013 в 8:25след.
Really weird camera-spinning, can't skip intro, and can't open overlay
After restarting my laptop for some Windows 7 updates, I started TF2 to find that I couldn't skip the intro before the menu. I thought it was odd, but passed it off since it wasn't serious. However, when I attempted to actually play, my camera was stuck in an endless spinning motion, only facing up or down and just spinning around really fast. The cursor had been functioning normally otherwise, obviously, but it was just the TF2 gameplay that was affected (it didn't happen if I opened the menu during the game). If I attempted to move the mouse in the opposite direction, I could slow down the spinning a bit, but there was still constant motion, and obviously it wasn't controllable at all.

After a restart of TF2, Steam, and the computer failed to resolve this, and a number of other possible factors were eliminated (a couple of keybinds I had recently added, my mouse's custom buttons which I had just customized for TF2), I poked around in the options, and enabled the "raw input" checkbox under the Mouse tab, which magically fixed the issue. So apparently some weird software-side issue was going on, and I dunno why.

However, my troubles weren't over. I then found out I couldn't open the overlay with Shift-Tab either. I could still open it by clicking "Read More" on a news snippet in the main menu, but I couldn't close it or open it again by using Shift-Tab (I had to click the link that says to go back to the game).

So, I'm guessing these probably have something to do with each other. I'd like to figure out exactly what was screwing up my mouse inputs, and obviously the Steam overlay is crucial in a game like TF2 where alt-tabbing could screw you over if playing. Plus, not being able to skip the intro is pretty annoying. Anyone have any clue at all what could have happened to cause these things and how I could fix them (if they're actually related at all)? Any assistance would be greatly appreciated.

Edit: If anyone is still reading this, it was Synergy[synergy-foss.org] that was messing with everything. It had started automatically in service mode, so I didn't notice it until I poked around in the Services tab in Task Manager. Just letting people know this is resolved.
Последно редактиран от Skirmisher; 21 февруари 2013 в 4:29след.
Показване на 1-1 от 1 коментара
< >
Tsunami 11 юли 2013 в 4:57след. 
I have this same problem but on a mac. I cant click raw input, and i dont have "synergy". any help?
Показване на 1-1 от 1 коментара
< >
На страница: 15 30 50
Дата на публикуване: 14 февруари 2013 в 8:25след.
Публикации: 1