Team Fortress 2
© Neui ™ Feb 9, 2013 @ 12:44pm
TF2 is closing at mapchange/dissconnect
My problem is, TF2 is CLOSING at mapchange or at disconnect. There isn't any warning or "hl2.exe has stopped working". (I reinstalled TF2 too, but still the same problem)
< >
Showing 1-6 of 6 comments
© Neui ™ Feb 11, 2013 @ 11:21am 
No idea? (I installed the Windows 7 (64-Bits) Updates, adding parameter "-dxlevel 110", used the "Check ingameData", still the same problem)
Castelia Feb 11, 2013 @ 12:46pm 
>-dxlevel 110
There is your problem
TF2 is a DirectX 9 game.
© Neui ™ Feb 12, 2013 @ 6:24am 
i man "tested -dxlevel 110"
I'll try "-dxlevel 90"

EDIT: Nope, TF2 is still closing at mapchange.
Last edited by © Neui ™; Feb 12, 2013 @ 6:51am
Castelia Feb 12, 2013 @ 1:54pm 
Try clearing your launch options, see if that fixes it.
If not: add -windowed to the launch options, try again
If still not, try this in your launch options:

-heapsize X

Replace X with this:
The amount of RAM you have in your PC in Gigabytes, Multiply that by 1024.
THEN multiply that by 1024 again.
Divide that by two.

Example: 8 GB of Ram
8 x 1024 = 8192
8192 x 1024 = 8388608
8388608 ÷ 2 = 4194304

This gives the game up to 4 GB of ram to use, as i assume it is crashing due to a ram error.


If STILL NOT: Re-install. If it STILL doesn't work: go through and 100% remove traces of TF2 from your PC.

Uninstall TF2 through steam, then check your steamapps folder for any of these and delete them if they are still there:

Multiplayer OB Binaries.gcf
Source 2007 Shared Materials.gcf
Source 2007 Shared Models.gcf
Source 2007 Shared Sounds,gcf
Team Fortress 2 Content.gcf
Team Fortress 2 Materials.gcf
Team Fortress 2 Client Content.gcf
Base Source Shared Materials.gcf
Base Source Shared Models.gcf
Base Source Shared Sounds.gcf
OrangeBox Media.gcf

Then go into your user-specific folder (Or folders if you have multiple accounts), and delete the Team Fortress 2 folder.

Be sure to empty the recycle bin.

Then re-download.

I have this discussion followed, so let me know if this doesn't work by commenting here~
© Neui ™ Feb 14, 2013 @ 11:58am 
The RAM didnt worked.

But i re-installed TF2 (Downloaded it now from UK-London) and it worked. (At the second reinstall..) and TF2 is working. Thanks for helping. :)
Castelia Feb 14, 2013 @ 12:10pm 
No worries man.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Feb 9, 2013 @ 12:44pm
Posts: 6