Team Fortress 2
TF2, Ubuntu and Intel Intergrated Graphics - OpenGL Error
Before you say anything, I know TF2 won't run well if at all on integrated graphics. I just want to see if I can squeeze any FPS at all out of an old ubuntu laptop with chris's fps config + playing on an orange map. So I've installed the game and I try to open it, but when I do I get this error;

Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I've looked online and found some fixes but none seem to work. I'm a n00b at Linux so please try to make any help (which is greatly appreciated in advance) for the simple minded such as myself. As I said I'm running Ubuntu with Intel Graphics + Processor.
Thanks, Freeze.
< >
Affichage des commentaires 1 à 7 sur 7
I have the same problem trying to run Counter Strike Source on integrated sandy bridge Intel graphics.
Here is my glxinfo: http://pastebin.com/C7Ee3mA0

Thank you for your help.
Intel is not supported atm, you will have to wait for a fix from intel basically if that ever happens or if someone finds a work around.
Changing repository for X11 and updating helped. If someone will have similar problem (and using OpenSuse) please try to follow instructions on http://en.opensuse.org/SDB:Team_Fortress_2 in "Video problems" section.
Thanks.
Dernière modification de ManiekQ; 18 fév 2013 à 18h52
Freeze - Currently in LA a écrit :
Before you say anything, I know TF2 won't run well if at all on integrated graphics. I just want to see if I can squeeze any FPS at all out of an old ubuntu laptop with chris's fps config + playing on an orange map. So I've installed the game and I try to open it, but when I do I get this error;

Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I've looked online and found some fixes but none seem to work. I'm a n00b at Linux so please try to make any help (which is greatly appreciated in advance) for the simple minded such as myself. As I said I'm running Ubuntu with Intel Graphics + Processor.
Thanks, Freeze.
"Either your video card is unsupported"
What do you think the problem is?
Dernière modification de icehat BAD RATS 2 HYPE; 18 fév 2013 à 18h47
Freeze - Currently in LA a écrit :
Before you say anything, I know TF2 won't run well if at all on integrated graphics. I just want to see if I can squeeze any FPS at all out of an old ubuntu laptop with chris's fps config + playing on an orange map. So I've installed the game and I try to open it, but when I do I get this error;

Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I've looked online and found some fixes but none seem to work. I'm a n00b at Linux so please try to make any help (which is greatly appreciated in advance) for the simple minded such as myself. As I said I'm running Ubuntu with Intel Graphics + Processor.
Thanks, Freeze.
I would try not using Chris's FPS config.
We're talking about OpenGL, here. Entirely different beast.
Protox a écrit :
Intel is not supported atm, you will have to wait for a fix from intel basically if that ever happens or if someone finds a work around.

so people who has this problem have to wait? damn. i could really use fix for this problem :,(
< >
Affichage des commentaires 1 à 7 sur 7
Par page : 15 30 50