Team Fortress 2
I can't find servers anymore?
Yesterday upon launching Team Fortress 2 for the millionth time I noticed that I could not find a single server in the server browser, nor could I join a friend's game in progress (Failed to connect after 4 retries). On other games, such as Left 4 Dead 2 or DOTA 2, I have no problem finding a game. I would also like to note that yesterday my Google Chrome stopped responding outright, giving me Error Code 138 every time I tried. Mostly I am wondering if anyone else is having this problem, but a fix would be a miracle. So far I have tried the following to no avail.

-Adding the program to Firewall exceptions.
-Disabling the Firewall entirely.
-Turning off virus protection
-Restoring the system to a point preceding the incident.
-Flushing the DNS

If you have had this problem with either TF2 or Google Chrome, please say so here. Any ideas for fixes are also welcome. I just want to get back to collecting hats.

-I should also note that I can connect to the item server, just not game servers.

Thanks and Godspeed.
< >
Showing 1-15 of 32 comments
Wolfhowler Feb 2, 2013 @ 11:03am 
yeah its apperently saying to me needs to be connected to beta servers or something like that
it happened to me today when i installed the new update and i just deleted it and im curently reinstalling it. this happend at 12:00pm now its 7:00pm and its still installing -_-
i also cant connect to item server
let me know if you are successful
nope. 7 hours. nothin. restart steam... nothin

helpppp.... D':
error code 138 on my chrome too....
Ok, considering what I have tried and failed to reslove both issues I would have to say that google chrome must have had an update which is causing these issues. If we can contact support and let them know they may be able to fix it
well im curently trying to fix my problem. my antivirus was blocking it
does it work now?
buster925 Feb 2, 2013 @ 7:06pm 
Try right clicking and going to beta and look for steam pipe. It helped me with my half life being messed up
arucana Feb 2, 2013 @ 9:41pm 
same thing happened to me it wont allow me to join my friends
TC Feb 2, 2013 @ 11:29pm 
I encounter this problem every once in awhile. No idea what the problem is, I'm afraid.
Charmander Feb 2, 2013 @ 11:30pm 
its been happening to me too
Originally posted by G² Colonel Thunder:
I encounter this problem every once in awhile. No idea what the problem is, I'm afraid.
Does the problem go away on it's own or have you done something to correct it?
< >
Showing 1-15 of 32 comments
Per page: 15 30 50

Date Posted: Feb 2, 2013 @ 11:00am
Posts: 32