Team Fortress 2
Team Fortress 2 > 総合掲示板 > トピックの詳細
Launch Options
I had some Launch option questions i was asked about by some players, figured id post them here incase anyone else needed help with them.

It appears the people were having issues with the correct launch options loading even after restarting steam, i tested it myself and was stumped a little bit.

I did some trouble shooting, turns out that it matters which things you set first. This seemingly was never said before.

Heres an example.

-dxlevel 81 -high -w1360

Commands to run the game on Directx 8.1, High is for CPU processing priority, w stands for width and controls the resolution for launch.

It appears that this order (possibly -dxlevel81 first) caused an issue where it would not process the other launch options afterwards, nor save settings changed after.

This can be fixed by changing its order, set to your specifications.

-high -w -dxlevel

Thought id share this with the community, i was having this issue and never found a single post about it, so this should help those who are frustrated with changing setting in game everytime.
< >
1-10 / 10 のコメントを表示
The issue is the command lines not working right? Isn't the width command supposed to have a space between the -w and the actual ##?

example: "-w 1360"

Here's this while I'm at it.
最近の変更はSeymourが行いました; 2013年1月31日 21時24分
Nope, as far as i know it has always been without a space.

Ex : "-w1360".

The problem that i and many others were having was that apparently the order in which you type the commands does matter, which has never been mentioned before.

As soon as i changed my -dxlevel to the final command it functioned properly and stored my saved settings properly.
No you do need a space between the command line and the variable or it won't work properly.

Bad example: -w1920 -h1080
Good example: -w 1920 -h 1080
Thomson R の投稿を引用:
No you do need a space between the command line and the variable or it won't work properly.

Bad example: -w1920 -h1080
Good example: -w 1920 -h 1080
Nope, just -w(insert width) works. Its incorrect that you need a space, i can screenshot my command to show you it works without. You dont need -h either, it automatically chooses the height based on the width.
I tested it. You need a space unless you're not launching through steam or performing some other witch craftery.
Maybe it depends on OS. Whatre you running ? Im running Vista 64 bit.
It doesn't depend on the OS with the potential exception of Mac or linux.
最近の変更はSeymourが行いました; 2013年1月31日 22時55分
Thomson R の投稿を引用:
It doesn't depend on the OS.
Well if you dont believe me i can screenshot my commands :P lol I cant think of any other reason whyd itd work that way.
You probably have a config you're forgetting about. Go to your steam/steamapps/username/teamfortress2/tf2/cfg folder and look for anything you may have.

Autoexec.cfg is one of the first thing you would look at.
I have linux and tf2 doesn't work for me >:(
< >
1-10 / 10 のコメントを表示
ページ毎: 15 30 50

Team Fortress 2 > 総合掲示板 > トピックの詳細
投稿日: 2013年1月31日 21時11分
投稿数: 10