Nelkovski Jan 23, 2013 @ 5:24pm
"the server you are trying to connect is running an older version of the game" NEED HELP UPDATING
So recently i dont really know what i did to my tf2 an everytime i connect that message appears. If anyone knows how to update your tf2 or do something so i can play again i will be very gratefull :) SOLVED
Last edited by Nelkovski; Jan 23, 2013 @ 9:10pm
Showing 1-7 of 7 comments
< >
OverlordTomala Jan 23, 2013 @ 5:25pm 
It should update if it's set to auto. You could try running a verify to see if it recovers any missing or corrupted files.
Nelkovski Jan 23, 2013 @ 5:26pm 
its set to auto and i already verified :(
OrangeJuicePanda Jan 23, 2013 @ 6:22pm 
Try restarting steam or change your download server if nothing else works. Hope this helps!
Nelkovski Jan 23, 2013 @ 6:43pm 
ok ty
My grandparents live on the sun Jan 23, 2013 @ 7:51pm 
Stop time traveling...
Nelkovski Jan 23, 2013 @ 7:55pm 
thank dude helped a lot lol
Backdraft_|BC| Jan 23, 2013 @ 8:59pm 
TF2 Updates weekly, the servers sometimes take time to catch up so you are trying to get on a server that hasn't applied the update yet.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jan 23, 2013 @ 5:24pm
Posts: 7