FlamingDeath™ Jan 23, 2013 @ 10:51am
Display driver stopped responding and has recovered
Display Driver NVIDIA Windows Kernel Mode Driver, Version (insert version here) stopped responding and has successfully recovered.

This happens on Team Fortress 2 and no other game, I repeat, NO OTHER GAME
The game does not recover and I am forced to end task and reload!

I have tried all of the ridiculous fixes that people have suggested and yet the one thing that remains obvious to me, this only ever happens on TF2...

Sort it out Valve, I am fed up with this ♥♥♥♥
Showing 1-15 of 24 comments
< >
sm0 Jan 23, 2013 @ 11:05am 
Not using Nvidia myself, but I've seen this thread on the other steam forums were people are reporting with simillair problems. It might help you to understand the problem.

Last post is from a Nvidia employee about this issue.
Last edited by sm0; Jan 23, 2013 @ 11:16am
FlamingDeath™ Jan 23, 2013 @ 11:41am 
I appreciate the link. I have upgraded my drivers about 5 times since this problem started, thats how long its been a thorn in my side. I suspect it is shoddy hat code that is crashing the drivers, TF2 has become a mongrel
Crabislav Mar 2, 2013 @ 10:29am 
Exactly the same problem
Geforce GTX280 here
Last edited by Crabislav; Mar 2, 2013 @ 10:43am
Bal Mar 2, 2013 @ 10:41am 
Same thing. Nvidia GeForce 320.
Last edited by Bal; Mar 2, 2013 @ 10:42am
FlamingDeath™ Mar 2, 2013 @ 11:11am 
I have managed to fix the issue, as far as I can tell, have not crashed since I made the change, that change is I added the below to my launch option

-dxlevel 81 +mat_dxlevel 95

What a sad state of affairs that I have had to downgrade the DX version in use by TF2.

SIDE NOTE: Having just "-dxlevel 81" looked bad so i added "+mat_dxlevel 95" as well, this seemed to make it look better and also I now get the overlay from the cart which wasnt the case without it!
Last edited by FlamingDeath™; Mar 2, 2013 @ 11:13am
Crabislav Mar 2, 2013 @ 11:18am 
I'm currently trying this out:
1.Go to the cfg TF2 folder (C:\Program Files (x86)\Steam\steamapps\[your username]\team fortress 2\tf\cfg)
2.Open autoexec.cfg.
3.If there is no autoexec.cfg then right click anywhere in the blank space -> New -> Text Document
4.Open the new text document, click on File, Save As, then at the bottom where it says Save As Type change it to All Files (*.*). For the file name type in autoexec.cfg
6.Copy and paste the follow into the autoexec.cfg file:
alias res_sw "res_low"
alias res_low "mat_setvideomode 1024 768 0; alias res_sw res_normal"
alias res_normal "mat_setvideomode 1280 1024 0; alias res_sw res_low"
bind "o" "res_sw"

Whenever the nvidia driver crashes press the o button to be able to see TF2 again.
efflandt Mar 13, 2013 @ 9:12pm 
Your video card may be failing. I had cheap Chinese (Galaxie) GT 430 and just after its 1 yr warranty ran out I started getting that error in Win7 regardless of different nvidia drivers. In Linux I would randomly get a lack of keyboard or mouse click response, even though mouse cursor would usually still move. Eventually it happened more frequently.

I replaced it with EVGA GTX 550 Ti with 3 year warranty. No more problems in Win7 or Linux (both are 64-bit).
FlamingDeath™ Mar 14, 2013 @ 1:25pm 
Originally posted by efflandt:
Your video card may be failing. I had cheap Chinese (Galaxie) GT 430 and just after its 1 yr warranty ran out I started getting that error in Win7 regardless of different nvidia drivers. In Linux I would randomly get a lack of keyboard or mouse click response, even though mouse cursor would usually still move. Eventually it happened more frequently.

I replaced it with EVGA GTX 550 Ti with 3 year warranty. No more problems in Win7 or Linux (both are 64-bit).

So what you are suggesting, because one game (TF2) is crashing the video drivers, I should buy a new video card, your basically saying that TF2 is not the problem, it is my graphics card..

Please leave fault finding to the experts...

If i swapped out hardware at every software fudge i'd be broke
FlamingDeath™ Mar 15, 2013 @ 1:51pm 
The problem is simple, too much bloated code being added for hats and promotional items, not enough debugging and patching. That pretty much sums up TF2 in its present state.

TF2 has just becoming a launching springboard for 3rd party promotional marketing ploys, its less about a game now and more about "special items" to entice people to buy/download/utilise other games/apps/operating systems
Last edited by FlamingDeath™; Mar 15, 2013 @ 1:53pm
FlamingDeath™ Apr 2, 2013 @ 3:20pm 
Ok I'm 100% certain I've found the root cause of the problem. I've unticked "Use glowing effect" in multiplayer advanced options.

This option is the wallhack technology that valve introduced for objectives recently and obviously didn't do sufficient testing and placed that responisibility on me, the customer

I can now play the game using DX9.
100% Recycled Awesome Apr 2, 2013 @ 3:32pm 
Hmm. I had this problem with Windows XP. Moved to 7 and it went away. GTX 9800+ and now a GTX 560.
Dagger - gezel draak May 19, 2013 @ 12:31am 
hey guys,
Even though it is a video card problem, its actually the sound driver on the motherboard.
Try putting down the quality of your audio in the audio options tab..
Worked for me.

i got a GTX9800
Last edited by Dagger - gezel draak; May 19, 2013 @ 12:32am
New Year Movies May 19, 2013 @ 12:07pm 
I just had this issue yesterday - it was odd.
Dagger - gezel draak May 20, 2013 @ 1:42am 
dont necro, are you freaking kiding me -not so- SomeWittyUsername.. its 3 months old..
this problem is over 3 years old for me
Doom972 May 20, 2013 @ 1:45am 
People still care because people still have this problem. The latest update made it worse for me. It didn't happen so frequently in the previous version.
Showing 1-15 of 24 comments
< >
Per page: 15 30 50
Date Posted: Jan 23, 2013 @ 10:51am
Posts: 24