KrunkMasterGoon Jan 18, 2013 @ 12:34pm
TF2 FPS Problems (Help)
So for a while, I've been playing TF2, but recently I've been running into FPS problems. I don't know exactly what it is, but my TF2 lags like there is no tomorrow. Now my computer is no super computer, but it should be able to play TF2 without it looking like minecraft.

I've tried deleting old drivers, maybe I didn't do it correctly, if anyone could inform me of how to do it correctly, it would be very appreciated. Here are my specs, again, they're not godly, but I should be able to run TF2 at a decent graphical settings.

OS: Win. 8 32 Bit (Bought the upgrade for $45 off of the MS website, didn't give me option for 64 bit windows.)

RAM : 3 GB DDR2 RAM

GPU : Galaxy GT520

CPU : Intel Pentium Dual CPU E2180 @ 2.00 GHz per core

Lastly, maybe its my CPU? When idling, it seems to shift clock speeds, I don't know if this is normal or what, but I really need help, this is annoying, google is no help and if this has happened to anyone else, please help, I'm getting really desperate.

Thank-you in advance for any help

-Jonathan
Showing 1-3 of 3 comments
< >
the Jan 18, 2013 @ 1:07pm 
Has your computer been turned on for a long time? Have you tried tweaking your video options?
Amber Jan 18, 2013 @ 2:34pm 
hello.

my game lags too. i was always able to run it smoothly but havent played for the last 2-3 weeks and all of a sudden it lags like hell. even in offline mode.

i tried to change video settings, validate and verify and what not, but it doesnt help. it lags.

ghost of delete key Jan 21, 2013 @ 1:20pm 
Your specs are FAR better than mine...
(Inspiron 8600 1.6GHz Celeron - 2GB RAM - GeForce FX Go5200 O.o )
yet I have no problem running the game, other than the occasional lag. Usually it's just latency jitter, but once in a while it's all out local processor stutter, likely from a competing process.

You say the machine is changing processor speed, and indeed it does, that's SpeedStep technology, and about every Pentium these days is so equipped. It's supposed to be seamless, but we all know how that is. To "disable" this, (i.e. to lock it into the high speed,) you need to adjust your machine's power profile to "Always On". You can use any monitor you like to watch the processor's speed, it should stay at the high speed when idle.

For details: http://www.intel.com/cd/channel/reseller/asmo-na/eng/203838.htm
read the section "How do I use Enhanced Intel Speedstep® Technology?"

Other than that, try adjusting the DirectX settings and/or play with different screen resolutions in-game, and consider creating a game profile in your machine's graphics manager. You will find a group of settings that run nicely with decent display.
Last edited by ghost of delete key; Jan 21, 2013 @ 1:22pm
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jan 18, 2013 @ 12:34pm
Posts: 3