Dave Dec 24, 2012 @ 1:14pm
TF2 low FPS with enthusiast PC *PROBLEM SOLVED*
I'm getting around 100fps when not in combat. It drops to about 10 when looking directly at someone. It's hard to play with such low fps. Has anyone had this problem and fixed it before?

GPU: Radeon HD 7970
CPU: AMD-FX 8 core
Driver is catalyst 12.10
8 gig RAM

I don't think other information is required but i can tell you that nothing is bottlenecked, PC has enough cooling and power.

I can play every other game on ultra at a constant 60 or more fps.

***I SOLVED THE PROBLEM I WAS HAVING, SCROLL DOWN THE THE BOTTOM OF PAGE 1 FIND MY SOLUTION***
Last edited by Dave; Jul 13, 2013 @ 8:23am
Showing 1-15 of 29 comments
< >
sherlock Dec 24, 2012 @ 1:17pm 
hmm check your computer AND graphic card settings they may be set to low settings(btw nice computer spec you have there)
Sinatra Dec 24, 2012 @ 1:34pm 
Download latest drivers, I have exactly the same setup as you.
Dave Dec 24, 2012 @ 1:41pm 
I'll download the drivers. Will reply if it works out.
Sinatra Dec 24, 2012 @ 1:45pm 
Make sure you download 12.11 beta.
Dave Dec 24, 2012 @ 2:01pm 
drivers did not change anything, still getting around 10 fps. Thanks for trying though. I'll keep at it and if I figure out how to fix it i'll post the solution.
Dave Dec 24, 2012 @ 2:49pm 
So far I've tried:
Updating to catalyst 12.11 beta drivers. no change
Flashing my MOBO, CrosshairV formula. no change
Putting all setting on low (used to be all very high). no change
Using chis' FPS.gcf file. no change
Deleting tf2's folder in /steamapps/. and restaring tf2. no change

My pc ahould be able to steamroll tf2. I'm guessing that my hardware is maybe too new and it's a driver issue. I'll keep trying.
Will post results.
Dave Dec 24, 2012 @ 4:44pm 
Tried running in compatibility mode. no change
Tried running it with direct x9 and 8. no change.

I hate it when I'm looking for a fix online and people don't post how they fixed their problem in their thread.
I'll try again tomorrow.
41noob Dec 24, 2012 @ 5:38pm 
your computer shouldn't be able to steamroll tf2

it should crush it, to the brink of death, spit on it, then run it over with a tank...after running it over with a tank smash a skyscraper against it, and if it's still not dead nuke it with all of the worlds nukes

that's what your computer should be able to do to tf2.

in all seriousness:

what are your current settings? (or before) you changed everything?
Dave Dec 24, 2012 @ 6:17pm 
Multicore rendering is on. no change.
Tried a benchmark just to make sure my hardware works. It does.

41noob
Settings are all maxed out right now, It does not matter if I put 0xAA or 8xAA. Framerate still
stays between 20 and 5 in a firefight. High and Low settings don't change a thing.

I'll eventually figure this out. I always do.
Dave Dec 24, 2012 @ 9:30pm 
Turns out AMD's Bulldozer series is having trouble lately with fps in some games.
Games designed with single and dual cores can't spread the load effectively over FX's 8 cores.

Solution is to update your MOBO. bad thing is I just updated mine and it didn't work.
I also downloaded the hotfix for bulldozer from Microsoft. Didn't work.

I'm going have to wait for a driver update by either AMD or Microsoft.
It's a shame, I'll keep looking around. Maybe I can fix it somehow.
I will post results if i have any results.
Flynt Dec 25, 2012 @ 12:25pm 
So this guy syas it will run if you turn the clock down to 2.8, might want to compare notes/ Good luck
http://steamcommunity.com/app/440/discussions/0/846940248300346037/

41noob Dec 25, 2012 @ 1:06pm 
https://raw.github.com/cdown/tf2configs/master/maxquality

get that, it's chris' max quality config (don't confuse with max frames) it turns up everything to the absolute max, it could be that your putting too much load on your cpu.

unfortunately, i have heard bulldozer is a pile of rubbish for 8 cores and even the intel i5 2500k quad core blows the fx 8 core out of the water.

even if so, that cpu is still very powerful. there's absolutely no reason you should be getting such low frames.

check your task manager and see your cpu usage during idle.
Last edited by 41noob; Dec 25, 2012 @ 3:19pm
Dave Dec 26, 2012 @ 7:42pm 
Problem SOLVED

I went into AMD Vision Engine Control
Set an application profile for TF2
Anti-Aliasing: Use application settings
Morphological Filtering: ON
Filter: Standard
Anisotropic Filtering: Use application settings
Tessalation: Use application settings
Texture Filtering Quality.: High quality
Surface Format Opt.: ON
Wait for vertical refresh: Off, unless application specifies
AA mode: Multi-sample AA
Triple buffering: ON

BAM, after trying everything I could, and 3 days wasted. There you have it.
A solution.

Hope this helps someone
bluehawk Jan 19, 2013 @ 12:28pm 
Originally posted by David "Dave" Davidson:
Problem SOLVED

I went into AMD Vision Engine Control
Set an application profile for TF2
Anti-Aliasing: Use application settings
Morphological Filtering: ON
Filter: Standard
Anisotropic Filtering: Use application settings
Tessalation: Use application settings
Texture Filtering Quality.: High quality
Surface Format Opt.: ON
Wait for vertical refresh: Off, unless application specifies
AA mode: Multi-sample AA
Triple buffering: ON

BAM, after trying everything I could, and 3 days wasted. There you have it.
A solution.

Hope this helps someone
Thank you so much this was helpful never even thought of that
Pob* Apr 27, 2013 @ 8:27am 
Originally posted by Dave:
Problem SOLVED

I went into AMD Vision Engine Control
Set an application profile for TF2
Anti-Aliasing: Use application settings
Morphological Filtering: ON
Filter: Standard
Anisotropic Filtering: Use application settings
Tessalation: Use application settings
Texture Filtering Quality.: High quality
Surface Format Opt.: ON
Wait for vertical refresh: Off, unless application specifies
AA mode: Multi-sample AA
Triple buffering: ON

BAM, after trying everything I could, and 3 days wasted. There you have it.
A solution.

Hope this helps someone

Seems to have improved my FPS too, thanks!
Showing 1-15 of 29 comments
< >
Per page: 15 30 50