killthyneighbour Dec 18, 2012 @ 3:44am
hl2.exe - Not responding (TF2)
Every time I join a server (very common on Turbine), hl2.exe stops responding. I've done numerous things to try and fix it such as Reinstallation (several times), Defrag, checking validation of game files, turning sync on and off, messing around with the launch options, display options, graphics options, advanced options, you name it and I've probably tried it. Ever since I updated TF2 it's been quite the little ♥♥♥♥. I've thought about it, pondered, I think it might be caused by ads, possibly. Because I remember TF2 working (in the stage that it wasn't) when I joined a 2-Fort server which played no ads. Not entirely sure, if ANYONE has suggestions ABOVE what I previously stated. I'm all ears, I want to be able to play TF2! It's a good game!
Showing 1-15 of 50 comments
< >
KindVirus [OPST] Dec 18, 2012 @ 3:56am 
Same thing here bro. But I started yesterday.

Anyway, I haven't tried this yet, but Deleteing your Tf file Might work. You'll lose all your mods and stuff though. But it might just work.
killthyneighbour Dec 18, 2012 @ 4:00am 
You mean the TF2 icon on my desktop? Or...
I don't want to have to reinstall it again, as I've already done such a copious amount of times.
KindVirus [OPST] Dec 18, 2012 @ 4:18am 
computer > Local Disk > Program Files > Steam > Steamapps > [Your Username} > Team Fortress 2 > TF See your TF File? Delete it, People recomended this to me before when I had a differant Crashing kind, It didn't work though. But I think it might work for this one. Btw, I think The Ads MIGHT be the cause. I went to my favourite server which apparently, Forced me to look at an Ad for 30 seconds. :L I crashed While looking at it.
killthyneighbour Dec 18, 2012 @ 4:39am 
I won't have to reinstall it again if I delete the TF file, will I?
It took 10 hours last time, too long.
KindVirus [OPST] Dec 18, 2012 @ 4:45am 
Nope, but you'll have to redownload custom sounds and Maps and all, but you can go to normal maps like 2fort. Tell me If it works, I came back after crashing with the same problem again O_o
killthyneighbour Dec 18, 2012 @ 5:02am 
Nope, still doesn't work. The ads must be related to the problem.... Bad thing is, if I do turn off the ads, most servers won't let me play unless I enable them. I just want to play some TF2 that I paid for. -.-
Greype Dec 18, 2012 @ 6:05am 
1. Go into your library and right click TF2
2. Click properties on the bubble that comes up
3. Click "Set launch options" in the new steam window
4. paste: -window -dxlevel 70 +mat_forcehardwaresync 0
No for-sure that this will work but when I have a problem I do that.
killthyneighbour Dec 18, 2012 @ 6:14am 
That didn't work either, unfortunately. I can't see my stats anymore either, Valve needs to get their ♥♥♥♥ together. I paid, and all I want to do now is play, simple.
Eustace{S.T.A.R.S](2411) (banned) Dec 18, 2012 @ 7:39am 
next time don't download huds or skins :)
killthyneighbour Dec 18, 2012 @ 7:55am 
I've downloaded neither, TF2 just killed itself, basically.
killthyneighbour Dec 18, 2012 @ 11:22am 
BUMP! I need help with this ♥♥♥♥, there oughta' be someone who knows what to do.
Name_Goes_Here Dec 18, 2012 @ 11:27am 
I had a similar problem when trying to load it up on my laptop. I found out that my graphics card didn't allow me to play on servers. It was an Intel Chipset Family Graphics Card (or something like that). If you do have one of these graphics cards, get a new PC or get a new graphics card.
Tolna Dec 18, 2012 @ 11:34am 
Yeah been seeing something similar it has to be either the Ads from servers with MOTD things or the item server.

I notice Team Fortess 2 in my library goes to "Syncing" after the crash. I'm waiting awhile for a patch to see if it gets better. Still playable, usually lasts long enoigh for 1-2 matches.
killthyneighbour Dec 18, 2012 @ 11:40am 
It has always worked smoothly until I updated Windows (and probably Steam/TF2), there was no problem at all. But now it seems I can never get past the ads without hl.2.exe dying on me.
[SSC] Jason Dec 18, 2012 @ 12:21pm 
Just disable HTML MoTDs in advanced options.
It worked for me.
Showing 1-15 of 50 comments
< >
Per page: 15 30 50
Date Posted: Dec 18, 2012 @ 3:44am
Posts: 50