Pedro Papadópolis' Dec 1, 2012 @ 8:01pm
Unable to load metamod plugin
Hello every1,

Recently I'm trying to setup an TeamFortress 2 server, I've done it, but now I'm stuck in metamod and source mod installing part. That simply does not work, I always receive the following error in the console: "Unable to load plugin "../tf/addons/metamod/bin/server"" and I tried a hundred of different ways to fix it!

Solutions that I've tried:
- Change the path in metamod.vdf from "../tf/addons/metamod/bin/server" to "../tf/addons/metamod/bin/server.so" or "../tf/addons/metamod/bin/server.so" or "../tf/addons/metamod/bin/server_i486.so"
- Reupload all ♥♥♥♥ using binary mode option in FTP
- Load plugin using plugin_load command in the game console

Additional information:
- I'm running the server in a CentOs 32 bits O.S.
- I'm uploading files using FileZilla (FTP)
- I'm managing all stuff via SSH
- Yes, my metamod.vdf is in addons folder
- Yes, I'm loading metamod instead of sourcemod
- Yes, my sourcemod.vdf is in addons/metamod folder
- Yes, I downloaded all files updated (Metamod version: 1.9.0, Sourcemod version: 1.4.6)
- Yes, my english is terrible


If someone have the solution, stay free to save my day.
Showing 1-4 of 4 comments
< >
German Dec 2, 2012 @ 8:36am 
i'm having the same problem
Iniquity Dec 2, 2012 @ 8:45am 
same here. Centos6 32 bit. Tearing my hair out.
Iniquity Dec 2, 2012 @ 8:47am 
i haven't tried this, but it looks to be the solution. Working on this now (really should be on the main page of metamod IMO. TF2 isn't exactly some unheard of mod.....)

https://forums.alliedmods.net/showthread.php?t=199319
Iniquity Dec 2, 2012 @ 8:52am 
confirmed, this works
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Dec 1, 2012 @ 8:01pm
Posts: 4