The Nightmare Tank May 3, 2013 @ 11:37am
SteamPipe and YOUR Custom Files [Fix Thread]
Because so many people seem to be struggling with getting reskins working again following the SteamPipe conversion for TF2, I have decided to provide information on getting your stuff working again.

Firstly, the TF2 folder has been moved. It is no longer at
Steam\SteamApps\<username>\Team Fortress 2

But is instead at
Steam\SteamApps\common\Team Fortress 2

This is for easier convenience. Now, as for reskins, they must be added into the custom folder located in the tf directory of the above path, and must be added with a name to the root folder. Let me give you an example...

Before the conversion, I made use of an MvM reskin that turned the robots Grey (Like in the trailer). I wanted to carry this over, so what I did was I took the reskin files that I found at
Steam\SteamApps\common\Team Fortress 2\tf\download\materials\models\bots

And I cut-pasted them into...
Steam\SteamApps\common\Team Fortress 2\tf\custom\

However, this did NOT reactivate my Grey robot reskins, I had missed an important step. What I then did was I made a new folder named "GRY Robots" and moved the files into there. So at the end of it all, I had this path to my reskins:
Steam\SteamApps\common\Team Fortress 2\tf\custom\GRY Robots\materials\models\bots

And they started working again, like before. This should work with any reskin or remodel in TF2. This also appears to work with HUDs as well, as posted by [HLSF] Jarate King/JarKin:
Originally posted by HLSF Jarate King / JarKin:
I can say custom HUDs work, I'm running one right now. As do materials and the like.

But all in all, following those steps SHOULD re-enable your reskins again. Post in the thread to let me know if there are problems.
Last edited by The Nightmare Tank; May 3, 2013 @ 3:56pm
Showing 1-15 of 56 comments
< >
J_ͣ_ͬ_ͣ_ͭ_ͤ King ˙ ͜ʟ˙ May 3, 2013 @ 11:39am 
I can say custom HUDs work, I'm running one right now. As do materials and the like.
The Nightmare Tank May 3, 2013 @ 11:40am 
Thanks for that, I'll update the Original Post...
dustmotes May 3, 2013 @ 11:53am 
I'm pretty sure I've followed these steps, but my skins still aren't working. Do I have to rename the folders to somethign specific or what?
The Nightmare Tank May 3, 2013 @ 11:55am 
Once you're in the "custom" folder, add a new folder with the name of the reskin (Can be anything) and in there, add the files leading up to the correct directory. For example, if you have a Scout reskin, the files should be in...
\Team Fortress 2\tf\custom\Scout reskin\materials\models\player\scout
...and be inside the folder marked "scout"
DubstepEnderFox May 3, 2013 @ 11:56am 
Heya forum mods~!

Can we please have this made into a sticky thread?

I'm asking because we have WAY too many people asking questions about Steampipe and fixing their custom files AND simply NOT reading around for solution threads such as this one. This would REALLY reduce the spam threads and provide a central place for everyone to gather and discuss fixes for the current update.

Please and thank you in advance! <3
Last edited by DubstepEnderFox; May 3, 2013 @ 3:48pm
dustmotes May 3, 2013 @ 11:58am 
Never mind, it turns out I had one folder too many for each one.
The Nightmare Tank May 3, 2013 @ 11:59am 
Ah! Well at least they're working now, right...?
The Nightmare Tank May 3, 2013 @ 3:16pm 
Bumping this back up, 'cause I'm seeing a couple SteamPipe-related complaint threads...
DubstepEnderFox May 3, 2013 @ 3:50pm 
Maybe you should try a more eye-catching thread title:

"Steampipe and YOUR Custom Files [Fix Thread]"

Yeah then?
Last edited by DubstepEnderFox; May 3, 2013 @ 3:51pm
The Nightmare Tank May 3, 2013 @ 3:53pm 
Could try it for a bit...
The Nightmare Tank May 4, 2013 @ 4:39am 
How can nobody conduct searches for fix threads, first? Why are the first couple pages littered with complaints about not getting HUDs workin' and whatnot...?
DubstepEnderFox May 4, 2013 @ 5:15am 
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe." - Albert Einstein

That's why.
Spyke May 4, 2013 @ 6:35am 
Originally posted by HLSF Jarate King / JarKin:
I can say custom HUDs work, I'm running one right now. As do materials and the like.
Have you any idea how to use different HUDs on different accounts?
J_ͣ_ͬ_ͣ_ͭ_ͤ King ˙ ͜ʟ˙ May 4, 2013 @ 7:31am 
Originally posted by Spyke | Re-ndering:
Originally posted by HLSF Jarate King / JarKin:
I can say custom HUDs work, I'm running one right now. As do materials and the like.
Have you any idea how to use different HUDs on different accounts?
No clue myself, it may be possible to use a script to change huds using hud_reloadscheme and some crazy auto-file changes with something though. Hopefully it'd come with a new option though as of steampipe. The developper wiki is down for me at the moment so I can't confirm it just yet, but I'll certainly look into it when I can.

EDIT: while I'm looking the only solution I know can work is to have the two huds in their own folders in custom, then once you need to play with one account place the one you aren't using at the desktop or somewhere that won't get loaded but is easy to access for when you use the other account.
Last edited by J_ͣ_ͬ_ͣ_ͭ_ͤ King ˙ ͜ʟ˙; May 4, 2013 @ 7:43am
Dragon the magic Pyro May 4, 2013 @ 10:32am 
Nothing in downloads regarding my skins.
Showing 1-15 of 56 comments
< >
Per page: 15 30 50
Date Posted: May 3, 2013 @ 11:37am
Posts: 56