]Ƥ[-juniper ♡ bmg Apr 30, 2013 @ 6:21pm
MAJOR fps drop after Steampipe Update (not config related, either)
Hey all,

I got steampipe and backed up all of my configs, etc. I use chris's configs for fps stuff, have it set to directx 8.1, etc. My computer isn't the best, but tf2 is usually quite playable. Today after the update, I had 120 fps (amazing for my computer) that steadily dropped over a few minutes to.. zero. frames. per. second. ZERO.

So, my game is totally broken and unplayable now. I have done the stupid tech support "turn it off, turn it back on again" approach, nothing. My room mate did the update on his computer and it's working fine for him. I'm pretty much in endless rage mode over this right now.

Anyone else having this issue? Any ideas?
Showing 1-15 of 66 comments
< >
]Ƥ[-juniper ♡ bmg Apr 30, 2013 @ 6:44pm 
bump
invishiro Apr 30, 2013 @ 6:52pm 
maybe try taking off all those custom configs? It's supposed to increase the performance of the game somewhat, so maybe you don't need them anymore, or they aren't optimized for the game yet.
]Ƥ[-Longbeard the Pirate Turtle Apr 30, 2013 @ 7:12pm 
Removing the Chris' config does not help - I get 30 FPS without and 120 with. As soon as I move around or try to do anything related to playing the game, my FPS tanks to 20 or below.
ThunderBear May 1, 2013 @ 5:43pm 
I'm running TF2 on an old dell inspiron 1520. Playing with custom configs was the only way I got it to work well. Right now my configs are still in their normal place, but they no longer work. Super frustrating. I'm looking to figure out how to re-enable the custom configs so that I can play the game again.
J_ͣ_ͬ_ͣ_ͭ_ͤ King<#30000 May 1, 2013 @ 5:47pm 
Originally posted by ThunderBear:
I'm running TF2 on an old dell inspiron 1520. Playing with custom configs was the only way I got it to work well. Right now my configs are still in their normal place, but they no longer work. Super frustrating. I'm looking to figure out how to re-enable the custom configs so that I can play the game again.
Put them in the custom folder. Pretty much every other discussion here's got a little bit on how to do it.
elvissteinjr May 1, 2013 @ 5:54pm 
I can somewhat confirm fps drops since the conversion. At least me and my friend got some when the scene gets busier. We don't use any fps configs, rather high graphics settings but that stuff just worked fine before the conversion, so...
MYLOkai May 1, 2013 @ 6:00pm 
+1 FPS drops after conversion update.

Before update, all graphic settings on high, no FPS drop.
After update, FPS drops when lots of action.

Disappoint.
ThunderBear May 1, 2013 @ 6:01pm 
After a little searching I think I found the solution here http://etf2l.org/forum/general/topic-25164/page-1/
=(eGO)= Super-Nova May 1, 2013 @ 6:09pm 
yes, huge fps drop, my computer should, and used to smash tf2

]Ƥ[-juniper ♡ bmg May 1, 2013 @ 6:14pm 
I switched to linux thinking it was a windows problem but that did not fix it. I'm about to reinstall tf2 for the 4th time. Removing configs didn't work. ♥♥♥♥ty that this update that should have made this better for everyone actually made it worse.
J_ͣ_ͬ_ͣ_ͭ_ͤ King<#30000 May 2, 2013 @ 12:17pm 
Originally posted by ☥ juniper ☥ ksg:
I switched to linux thinking it was a windows problem but that did not fix it. I'm about to reinstall tf2 for the 4th time. Removing configs didn't work. ♥♥♥♥ty that this update that should have made this better for everyone actually made it worse.
Maybe you're just doin it wrong, I'm chris's config free and always have been and all the very mild amounts of lag I've had before are now gone. I can't see how chris's config suddenly wouldn't work anymore considering how it works.
]Ƥ[-juniper ♡ bmg May 2, 2013 @ 6:01pm 
I'm saying the FPS drops since steampipe came out have NOTHING to do with what configs someone has, so my configs are irrelevant. I am a laptop player, and while I don't have an integrated video card, I need to have configs to make TF2 run well, and it did run well before this update.
J_ͣ_ͬ_ͣ_ͭ_ͤ King<#30000 May 2, 2013 @ 6:09pm 
Originally posted by ☥ juniper ☥ ksg:
I'm saying the FPS drops since steampipe came out have NOTHING to do with what configs someone has, so my configs are irrelevant. I am a laptop player, and while I don't have an integrated video card, I need to have configs to make TF2 run well, and it did run well before this update.
Certainly is odd, unless some disable features have been disabled all that's in chris's config should still work, and I can only see the issue as being graphical. It may be possible to manually go through all the .vmt's and .vtf's and make them more efficient (in exchange for quality), but that'd take quite a bit of work.

Thinking about it, it'd probably be just as likely that the issue is the new system for file replacements (if they changed it). I don't really know how it works but with the custom support Valve might've left in a memory leak, so if you've got anything at all in custom I'd try backing it up and getting rid of it for now (configs are kept outside of the custom folder I believe), just to see how that works.
Mizzerabella May 2, 2013 @ 6:11pm 
I can't even play TF2, it closes after Valve logo screen.
J_ͣ_ͬ_ͣ_ͭ_ͤ King<#30000 May 2, 2013 @ 6:15pm 
Originally posted by Phan_:
I can't even play TF2, it closes after Valve logo screen.
Does your graphics card or driver or whatever support DirectX 9 and newer? Do you have any scripts / custom content / all that jazz? Did you try all the standard steps to fixing computer problems; restart your computer / reinstall tf2 / validate cache / etc.?
Showing 1-15 of 66 comments
< >
Per page: 15 30 50
Date Posted: Apr 30, 2013 @ 6:21pm
Posts: 66